Dodge Cummins Diesel Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
284 Posts
Discussion Starter #1
Got my Boost fooler Today . Not really any hookup instructions , just a couple pictures which looks like a 5.9

where do i hook it up in conjuction with the Edge ? is the MAP sensor on the intake Horn ?
 

·
Registered
Joined
·
1,927 Posts
If you want to get true readings, you need to hook it up between the edge and stock harness, not after the edge, so it should be stock, fooler, edge, stock
 

·
Registered
Joined
·
284 Posts
Discussion Starter #3
Thanks a found another post also but from what i read it is getting hooked up both ways
do not care about accurate Boost readings on edge , just want to make sure i am the most boost that it will give me
 

·
Registered
Joined
·
849 Posts
People have been saying that the Edge doesn't give accurate readings because it reads off of the ECM, but I am running the Edge and my water/meth controller has a boost line plumbed into the intake horn and the boost readings are identical.
 

·
Registered
Joined
·
284 Posts
Discussion Starter #5
People have been saying that the Edge doesn't give accurate readings because it reads off of the ECM, but I am running the Edge and my water/meth controller has a boost line plumbed into the intake horn and the boost readings are identical.
So which order do you have the fooler hooked up
 

·
Registered
Joined
·
1,927 Posts
^^The way i said above, i have the same setup.
 

·
Registered
Joined
·
849 Posts
Map sensor-boost fooler-Edge-stock harness as DodgeLuvr has stated above. Qzilla told me that this should be the way it is run.
 

·
Premium Member
Joined
·
286 Posts
i tried it both ways tonight just to see what works best. when i had it setup like this (map sensor, edge, fooler, stock) my egt's wouldnt get over 1350 degrees with the edge on 6 and the mp8 100% and my boost peaked at 37 and hung in the low 30's. with it setup ( map sensor, fooler, edge, stock) egt's would be up around 1450-1500 and boost peaked at 23. these readings were from the edge display. boost numbers might be a little off from what they really are but the egt's were very different. truck seemed to drive better with the first way hookup too. hope this helps
 

·
Registered
Joined
·
284 Posts
Discussion Starter #9
Thanks Everyone.
i found this, it is a post from Q-Zilla

Ok, if you have an Edge box here is how it needs to be installed.

Edge to Map Sensor, Edge Molded to Boost fooler Grey plug, Boost fooler molded plug to factory engine connector.

Not sure who here is telling people that but, they should not be.

They may be thinking Edge Insight and Not Edge Juice or something??? I have no clue but, the way I posted above is the correct way to install it and the only way that seems to work. I have no idea what Edge is or is not doing with that circuit but, from what we have seen and had feedback on this is the only way it works.
it seem the reverse of what you guys are running if i am understanding it Right
 

·
Registered
Joined
·
849 Posts
Ahh crap I posted that up wrong. I was tired. Juggs, the way you just posted is the way that I was told to hook it up. That post from Qzilla was actually a response to one of my posts. Sorry to confuse.
 

·
Registered
Joined
·
284 Posts
Discussion Starter #11
Thanks Again for your Help ,i will hook her up that way and Give it a Try

What kind of Boost #`s are you seeing & Do you feel any Difference in Resonse ?
 

·
Premium Member
Joined
·
286 Posts
i tried it both ways tonight just to see what works best. when i had it setup like this (map sensor, edge, fooler, stock) my egt's wouldnt get over 1350 degrees with the edge on 6 and the mp8 100% and my boost peaked at 37 and hung in the low 30's. with it setup ( map sensor, fooler, edge, stock) egt's would be up around 1450-1500 and boost peaked at 23. these readings were from the edge display. boost numbers might be a little off from what they really are but the egt's were very different. truck seemed to drive better with the first way hookup too. hope this helps
already answered your question juggs :thumbsup:
 

·
Registered
Joined
·
284 Posts
Discussion Starter #13

·
Registered
Joined
·
326 Posts
i tried it both ways tonight just to see what works best. when i had it setup like this (map sensor, edge, fooler, stock) my egt's wouldnt get over 1350 degrees with the edge on 6 and the mp8 100% and my boost peaked at 37 and hung in the low 30's.
That's the correct way.
 

·
Premium Member
Joined
·
258 Posts
That's the correct way.
That is the way I have mine and it works well.

Map sensor, edge, fooler, stock plug harness.:headbang:
 

·
Registered
Joined
·
849 Posts
Thanks Again for your Help ,i will hook her up that way and Give it a Try

What kind of Boost #`s are you seeing & Do you feel any Difference in Resonse ?
I had no gains in boost sustained or peak, so I think I had a faulty fooler. I should be receiving a new one in a week or so.
 

·
Registered
Joined
·
288 Posts

·
Registered
Joined
·
261 Posts
i tried it both ways tonight just to see what works best. when i had it setup like this (map sensor, edge, fooler, stock) my egt's wouldnt get over 1350 degrees with the edge on 6 and the mp8 100% and my boost peaked at 37 and hung in the low 30's. with it setup ( map sensor, fooler, edge, stock) egt's would be up around 1450-1500 and boost peaked at 23. these readings were from the edge display. boost numbers might be a little off from what they really are but the egt's were very different. truck seemed to drive better with the first way hookup too. hope this helps
i did the same thing and got the same results, I left mine sensor, edge , fooler, i don't it didn't seem to do anything the other way, i still can't run the mp8 all the way though.
 

·
Registered
Joined
·
849 Posts
i did the same thing and got the same results, I left mine sensor, edge , fooler, i don't it didn't seem to do anything the other way, i still can't run the mp8 all the way though.
Why can't you run the MP8 all the way up?
 
1 - 19 of 19 Posts
Top