Dodge Cummins Diesel Forum banner
1 - 15 of 15 Posts

Registered
Joined
49 Posts
Discussion Starter · #1 ·
My windshield wipers won't work on the intermittent, sometimes won't shut off even with the truck turned off or only work on continuous mode. I changed the directional switch and that worked for a week. Now it is doing the same thing.

Any suggestions?
 

Admin/Mod
I Still Know Nothing
Joined
4,049 Posts
The park switch on the motor is probably bad (common problem).

Solution is to replace the wiper motor.
 

TECH SPECIALIST
Joined
14,174 Posts
I just did the fix for this, pull the motor, pull the motor cover and the cover over the electronics. Sand the contacts some to remove the oxidation, spray it with white lithium grease and reassemble.

That fixed was applied to a wrecking yard wiper motor and works as expected. The insides did not look so hot and i suspect it had the same issue. I used a writeup on another forum to do this. Took several pics and can write it up here if needed.
 

Registered
Joined
3,818 Posts
I just did the fix for this, pull the motor, pull the motor cover and the cover over the electronics. Sand the contacts some to remove the oxidation, spray it with white lithium grease and reassemble.

That fixed was applied to a wrecking yard wiper motor and works as expected. The insides did not look so hot and i suspect it had the same issue. I used a writeup on another forum to do this. Took several pics and can write it up here if needed.
You should do that writeup here!
I had the same issue years ago and just replaced the entire wiper motor instead of pulling it apart, but I'd always good to save some coin.
 
  • Like
Reactions: steve05ram360

Registered
Joined
49 Posts
Discussion Starter · #6 ·
I live in Mexico where we take things apart and fix them. I would appreciate any instructions you can give me.

Mucho gracias amigos
 

TECH SPECIALIST
Joined
14,174 Posts
I live in Mexico where we take things apart and fix them. I would appreciate any instructions you can give me.

Mucho gracias amigos
Yeah i remember you were down there from a previous post. Should have one up in a day or so... Should not take long.
 

Registered
Joined
49 Posts
Discussion Starter · #10 ·

TECH SPECIALIST
Joined
14,174 Posts
Thanks again Steve. My mechanic followed the instructions you provided. The wipers are now working correctly.
Nice! Good to hear!! I think it is best to try and keep the OEM vs aftermarket on some parts, this is one of them.
 

Registered
Joined
3,818 Posts
Nice! Good to hear!! I think it is best to try and keep the OEM vs aftermarket on some parts, this is one of them.
Anything that can be rebuilt! Starters, alternators, wiper motors, etc.
 
  • Like
Reactions: steve05ram360

Registered
Joined
3,818 Posts
You still making parts?

Did you ever move out by the straights?
I make parts when I need em, hobby stuff, done a lot for my car, made some custom buckets for a projector retrofit for the Golf, been playing some high temp material. Printed some lowers etc.

Still house hunting. We've had the rug pulled out from under us on a few houses, it's been very deflating to say the least.
 

TECH SPECIALIST
Joined
14,174 Posts
I make parts when I need em, hobby stuff, done a lot for my car, made some custom buckets for a projector retrofit for the Golf, been playing some high temp material. Printed some lowers etc.

Still house hunting. We've had the rug pulled out from under us on a few houses, it's been very deflating to say the least.
That sucks.... Ding give up!
 
1 - 15 of 15 Posts
Top