Dodge Cummins Diesel Forum banner
1 - 13 of 13 Posts

·
Premium Member
Joined
·
1,364 Posts
Discussion Starter · #1 ·
First is the power lock for the rear driver’s side door does not work. I pulled off the cover and peeled off the plastic sheet. All of the rods are connected as they should be. I traced 4 wires from the harness under the speaker/behind the power window switch to the lock mechanism. I could not get the plug off to check anything. Will I have to take the lock off the door to test it? Also is there a way to repair it or do I need to get an entire new unit, and what do they usually run?

The second problem is my wipers they kind of do what they want when they want while the knob is on. Sometimes I have to crank it all the way to get them to move without stopping mid wipe then the intermittent function works. Some times while on any setting for the intermittent it will wipe 3 to 5 times in a row like on the no delay setting low speed then go back to a normal interval. Where should I start looking and what should I look for?
 

·
Registered
Joined
·
937 Posts


Likely the cause of your lock not working.

As for the wipers likely the cause is the Multi Function Switch. There is a recent thread about fixing it.
 
  • Like
Reactions: insanity05

·
Registered
Joined
·
44 Posts
I have an added question about the locks. In my Cummins (03 qcsb) my electric locks work when my key is in acc or the engine is running but when my key is off or not in the ignition period none of them work. I can't lock or unlock my truck electronically without the key being in it. So without saying my key fob is no use to me either and its really annoying cuz as it gets closer to another wonderful Iowa winter I'd like to be able to start my truck and lock my doors if need be and still get in with my fob. Any ideas of what might be going on there? Thanks.
 

·
Registered
Joined
·
937 Posts
That problem I have no idea.
 

·
Premium Member
Joined
·
1,364 Posts
Discussion Starter · #5 ·
Big ram check the batteries in the fob. There is usually a device at autozone for this.

Geezir I will check for broken wires, I didn't see any readily but I also didn’t pull them out of the jamb either.
 

·
Registered
Joined
·
937 Posts
I'd almost guarantee broken wires within the rubber.
 

·
Registered
Joined
·
44 Posts
But my locks don't work in the truck using the lock lever on the door unless the key is on. I guess I haven't tried the fob while my key is on but I'm confused on why I have to turn my key on to lock or unlock my doors. My gf hates it when I fumble with my keys to unlock her door in a down pour Haha
 

·
Registered
Joined
·
832 Posts
Don't know about the locks, but as far as the wipers, try moving the adjustable steering up and down a few times. When my son's truck gets stupid, he moves it around and the wipers and high beams start working again. Apparently this is a very common problem with these trucks. That may help til you replace the multi function switch.
 

·
Premium Member
Joined
·
1,364 Posts
Discussion Starter · #10 ·
I will give that a try chip. I did find a way to take it apart clean and reinstal on here I will try that before buying a new one.
 

·
Premium Member
Joined
·
1,364 Posts
Discussion Starter · #11 ·
I get one thing fixed and something else goes out.:banghead: Now the pass side mirror defroster went out. It still moves with the switch and the small convex mirror still defrosts but the main mirror won’t defrost now. From the search looks easy to pop out but I will have to wait to see if I can fix it.
 

·
Premium Member
Joined
·
1,364 Posts
Discussion Starter · #12 ·
It was really easy to pop the mirror out. Once out I was able to test the circuits with my light tester. Because the obvious tear in the metal heater strip about ¼ of an inch from the tab wasn’t obvious enough. I think it can be repaired with some aluminum foil and tape once the protective layer is pealed back.

I should have this thread renamed insanity05’s electrical debacle of parts that are not completely necessary but annoying that they don’t work or work properly and how they are fixed.
 

·
Registered
Joined
·
5,359 Posts
I have an added question about the locks. In my Cummins (03 qcsb) my electric locks work when my key is in acc or the engine is running but when my key is off or not in the ignition period none of them work. I can't lock or unlock my truck electronically without the key being in it. So without saying my key fob is no use to me either and its really annoying cuz as it gets closer to another wonderful Iowa winter I'd like to be able to start my truck and lock my doors if need be and still get in with my fob. Any ideas of what might be going on there? Thanks.
Is this a new problem to you or you have had this problem ever since you own the truck?
It looks like when the key is off there is NO power going to your door circuits.
May be the PO did this mod. The power to the door lock circuits should ALWAYS on and not depending on the key position.
My own opinion.
 
1 - 13 of 13 Posts
Top