Dodge Cummins Diesel Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
256 Posts
Discussion Starter · #1 ·
Having an issue with the intermitten wipers (spelling?) when I put it on the lowest setting, some times it works, sometimes not. Others it will sweep 4, 6, 8 e.t.c times before it waits to engage again. Anyone have this happen? Oh and it only does it if the windshield is wet. Worked fine at the dealership dry.
 

·
Registered
Joined
·
318 Posts
Wipers

Hi
It's most likely the wiper motor. Common issue. If you can get it to act up, you will see on the scan tool that the scanner (and intermittent wiper module) is not seeing the "park" switch make contact when it's at the rest position, that why it does the multiple sweep thing, cause it waiting to see it park before it counts the time to delay the next sweep. Not all techs know about it. Ask the manager to check with the foreman or lead tech.
Good Luck
Charlie
 

·
Registered
Joined
·
603 Posts
Damn mine is doing the same thing. When I click it on the lowest intermittent setting it goes full boar and there are no more "intermittent" settings. Then when I turn them off they halt whereever they happen to be on the windshield. Really annoying. I was thinking it was the wiper switch on the column? How much was that to replace Mopar99360?
 

·
Registered
Joined
·
256 Posts
Discussion Starter · #5 ·
Parts and Labor, $225. The dealership i bought the Truck from is picking up the bill. Got it back yesterday afternoon. I'll let you know if that fixed my problem when it rains again.
 

·
Registered
Joined
·
603 Posts
Yeah i just tried mine out again today w/ no rain and they work spot on. Figures when you need them the most (rain) they fail.
 

·
Registered
Joined
·
256 Posts
Discussion Starter · #7 · (Edited)
Well, they are better, but that didnt completly fix the issue, they still sometimes will sweep 2 times, but then go back to 1 for awhile. They however have not just stopped, so I'm calling it good. The other part that could cause or contribute to the issue is some kind of computer board, which cost somewhere around 2 grand. I'm not going that route, thats for sure and I'm sure the dealership that said they would fix it wouldnt cover it anyway.
 

·
Premium Member
Joined
·
272 Posts
Mine has been having wiper issues also seems to be the TIPM totally integrated power module. computer board located under the fuses in the same box. about 800.00 from the dealer for the part so I am looking to wire mine up on a toggle to the low and high speed windings. I already replaced the wiper motor and the multifunction switch.
 

·
Registered
Joined
·
591 Posts
this sucks. same problem. im not haveing a good day. please post what fixes it
 

·
Premium Member
Joined
·
272 Posts
I wired in a spdt toggle switch from switched power to the high and low motor windings they do not self park and no intermitent but they do clean the windshield now. Mine would only run supper slow in the high speed setting before and burnt the high speed winding up in one motor. New motor and switch did not fix mine. From what i've found the wiper relay is built into the TIPM so no way to replace without replacing the entire board, located in the fuse box under the hood under the fuses.
 

·
Premium Member
Joined
·
272 Posts
I believe as the motor draws more amperage from age it burns out the light computer board controlled relays, this affects all wiper motor functions. My washer pump still works I just have to turn on the wipers manualy to clear the wiper fluid from the windshield. Also have to turn off when wipers are at the bottom of the windshield.
 

·
Registered
Joined
·
1 Posts
Washer / Wiper / Headlight dimmer problem

Hi everyone, I'm new to the forum and just recently purchased my first Dodge. I have an 07 3500 DRW Megacab with all the bells & whistles. I noticed when I attempt to put the high beam on or off the washer fluid sprays from time to time. And some times it wont do anything when I try to switch from low to high beam. Has anyone had a similer problem? Is it just the switch or something else.:confused013:
 

·
Your Delightfully Ginger Kentucky President
Joined
·
3,754 Posts
I thought this was just my problem. Glad to find out I need to look in that direction. I was thinking it was the console switch.
 

·
Registered
Joined
·
314 Posts
A couple of times now, my wipers have cycled when I open the door when the truck is not running..

Does anyone know the process to try and make Dodge pay for this…I have 79K on the clock.

I feel like this is a severe safety issue, and Dodge should be the one to cover it as a recall. My wipers have actually stopped working (on the intermittent setting) during the rain driving down the highway.
 

·
Registered
Joined
·
133 Posts
A couple of times now, my wipers have cycled when I open the door when the truck is not running..

Does anyone know the process to try and make Dodge pay for this…I have 79K on the clock.

I feel like this is a severe safety issue, and Dodge should be the one to cover it as a recall. My wipers have actually stopped working (on the intermittent setting) during the rain driving down the highway.
I know this is an old thread, but was there ever a conclusive fix for this? My son's '05 is doing the exact same thing. I tried searching, but I am getting different answers. Some say wiper motor, others say multi-function switch, and other says TIPM?
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top