Dodge Cummins Diesel Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
240 Posts
Discussion Starter · #1 ·
I posted a little while back that my truck was running like crapola. unplugged the Quad module and wholla it went back to normal.

lately the truck has a bit of hickup at idle (like a really faint miss) doesn't seem to have the power it once had (especially on hills) and seems to "dust" the cars behind me with a faint smoke that is really only visible at night. Truck starts as normal with no visible smoke on start up.

was wondering if the map sensor is shot since that's where the quad module plugged in?

thanks in advance for all the inputs.
 

·
Premium Member
Joined
·
145 Posts
Its going to blow a little smoke i got a 06 that does the same thing you just see it more at night cause its in the headlights. As for the power have you checked your lift pump out those chips tend to burn stock ones up as they have to pump a lot more fuel. and depending on mileage you might check your valve lash. I have 60,000 on my truck and it need adjusted.
 

·
Premium Member
Joined
·
145 Posts
O yea might try draining your water out of your fuel filter or even replace it
 

·
Registered
Joined
·
240 Posts
Discussion Starter · #5 ·
fuel filter's been changed recently.

I had the valve's adjusted when i got the truck at that was approx. 55 000km's ago...could be due i guess.

thanks for the replies.
 

·
Premium Member
Joined
·
145 Posts
might suprise you even if it is a fresh fuel filter you hit one bad gas station get too much water and it messes everything up had it happen to me before and if you know how to check the lash i would do it my self whos to say they knew what they were doing.
 

·
Registered
Joined
·
240 Posts
Discussion Starter · #8 ·
the only code it throws is for an ignition key error which it's had since i bought the truck. has no bearing on the trucks health.

the truck is due for an oil change in about 1500km's so i'll change it agian at that time. i'm going to run a tank of biodiesel through it so that'll plug'er up real good!!

for the ease of it i might try and clean or inspectd the map sensor. i find it interesting that the driveability issues seemed to revolve around the chip which may have pwned the map sensor in the process.
 

·
TECH SPECIALIST
Joined
·
5,876 Posts
do you tow with it much?

biodiesel will clean the injector nozzles inside and out. most of the MAP foolers cause excessive overfueling leading to injector nozzle carbon buildup and nozzle spray pattern distortion. hard to clean off.

while your running the bio, hook up to something heavy wide high and flat nosed. pull hard and fast up some mountains, take the EGT to 1200d F and hold it there for at least 30 minutes. do several times.
removes carbon and deposit buildup inside and outside of the nozzles and the ring grooves, cleans the tops of the pistons off. No carbon hot spots to preignite diesel spray and screw up combustion timing.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top