Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 15 of 15 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
08 3500 full deleted H&S tuner broke a flywheel replaced it. while it was down pulled the front apart to replace front main seal and gasket so had to remove cam gear and injector pump gear reinstalled everything and now it is blowing out white smoke when the tuner is in stock if i put it in tow it goes away when it started blowing smoke i replaced all filters nothing changed replaced injectors and coded them To the truck still nothing has changed any ideas
 

·
Premium Member
Joined
·
15,533 Posts
Pretty sure you mistimed the cam when you reinstalled it. Why did you remove the cam gear again? Front main and timing cover gasket does not require that. Accessories case to black does if that is what you meant. Pulling and installing the cam gear in the truck is asking for trouble, you pull cam and gear as one and reinstall. Your problem is going to be in the cam timing somewher ebut hard to tell what went wrong with no visuals.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Pretty sure you mistimed the cam when you reinstalled it. Why did you remove the cam gear again? Front main and timing cover gasket does not require that. Accessories case to black does if that is what you meant. Pulling and installing the cam gear in the truck is asking for trouble, you pull cam and gear as one and reinstall. Your problem is going to be in the cam timing somewher ebut hard to tell what went wrong with no visuals.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
It's in time the one dot is in the center of the two tdc and everything is right and cam and crank has a key besides it drove fine after everything was replaced for several miles before it started happening
 

·
Premium Member
Joined
·
15,533 Posts
What injectors did you use for replacement? Can the white smoke be tracked to engine warm\cold? Does it do it all the time now or still randomly?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
What injectors did you use for replacement? Can the white smoke be tracked to engine warm\cold? Does it do it all the time now or still randomly?
It does it on start up hot or cold don't matter well on a cold day it harder to clear out it acts like a two stroke loaded up once it cleaned out its seems to run fine with the h&s tuner i DC id notice on stock the timing is at -3 when its smoking i can put it on tow and it goes to +0 and it clears up immediately
 

·
Premium Member
Joined
·
15,533 Posts
If it is smoking on startup and then clears that sounds like you have injectors leaking into the cylinder. What and who's injectors did you do replacement with?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #8 ·
I thought the same so i replaced them Bosch injectors with Cummins Nozzles and no charge at all
 

·
Premium Member
Joined
·
15,533 Posts
Remans or new? Did you buy them complete from a Bosch authorized dealer or some other party?
 

·
Premium Member
Joined
·
15,533 Posts
Yeah. Aside from the fact remans are junk and do not respond well to programming, I am convinced a lot of these alleged Bosch remans are NOT true Bosch remans. They may be remans and they may be Bosch injectors but they are not a certified Bosch reman injector. Would not doubt them being a chinese knock off. :(

If you are sure the cam was timed correctly, you are not losing oil thru the turbo, and all cylinders have good compression, valves are set correctly the diagnosis does not leave much except faulty injectors.

If those timing numbers you mentioned are pilot event then I would say again injectors are lazy or not setup correctly. Not to throw too many things at you but an old supported H&S tuner could be skewing results. If you unload it and you get smoke on start up then it clears up with rpm we are back again to questionable injectors.

What injectors did you have before were the symptoms exactly the same?
 

·
Premium Member
Joined
·
15,533 Posts
How many miles on the OE injectors? Just to make sure, you did check and replace the air filter?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #14 ·
260,000 on injectors air filter both fuel filters changed did a leak down test on injectors and fuel rail all shows good turned off injectors one at a time and two at a time and no different
How many miles on the OE injectors? Just to make sure, you did check and replace the air filter?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #15 ·
Just got back from dodge dealer and they said everything they can see looks good but at idle it's showing to be running under a 17% load and it should be at around 2% and they don't know why. I was told once i figured it out too come back and let them know what it was
 
1 - 15 of 15 Posts
Top