Dodge Cummins Diesel Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
My 92 dodge is smokeing white/greyish at idle. and it gets worse the more boost I run going down the road. I'm going to try bumping up the timeing. I'v read that it could be air in the fuel. I know I'v got one small fuel seep right at the pump on the inpute line. but how could air get in when my fuel pump is set with the 5-7 psi spring(I'v got a holly blue electric fuel pump). It has close to 300K on it.
 

·
Registered
Joined
·
472 Posts
Ya I have the same problem I have a 91 non intercooled w250 and what hapend to me was my pump sheared that half moon on the taperd shaft so i pulled another pump off a motor that i use for parts and all i get is heavy whight smoke:banghead: I have over 300k miles on it also :confused013:
 

·
Registered
Joined
·
472 Posts
Where can i find cheep rebuilt injection pumps in Tx for a 91 w250 non intercooled 4x4
 

·
Registered
Joined
·
253 Posts
Does it only smoke white?? Or does it stumble and miss when accelerating? If it does miss i would pull the injectors and send them to a shop to be pop tested/checked out. Just my .02
 

·
Registered
Joined
·
186 Posts
on the way home form buying my 92 it stated to miss and smoke white and I mean real bad so whats the frist thing one should do to any new rig. its change the filters. that fixed it. it din't help that after I payed the DA I had to go find the. Truck out of fuel on the side of the road about 10 blocks from his house.Ken
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
It runs fine exept for the white smoke. no missing or anything I dont think its doing as good on fuel as it did though.
 

·
Registered
Joined
·
253 Posts
check your fuel pressure, i bet its low.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #10
bumped the timing and it seems to be fine now . took it a 3or4 miles to clear up though. My fuil pressure was fine I'v got a gauge on it. Thanks
 

·
Registered
Joined
·
472 Posts
Thanks ill give them a call Diesel Injection was no help they wanted way to much to rebuild my pump
 

·
Premium Member
Joined
·
857 Posts
well whats done to your truck? is it possibly a headgasket? more boost = more rpms so the water pump is turning quicker putting more antifreeze in there. check your coollant level. if its dry thats your problem if its full i would cancel that guess lol
 

·
Registered
Joined
·
12 Posts
well whats done to your truck? is it possibly a headgasket? more boost = more rpms so the water pump is turning quicker putting more antifreeze in there. check your coollant level. if its dry thats your problem if its full i would cancel that guess lol
A water pump dosn't make pressure, its a non positive displacement pump. the pressure in your cooling system is from the water expanding as it warms.
 

·
Registered
Joined
·
644 Posts
Most likely advanced it.

The timing advance piston in these pumps will get sticky or just plain stuck after 18years and 300K mi. Depending on where it stuck/ sticks, that can cause the symptoms you described. If it is still the original pump, it's a good idea to have it gone through and new plunger return springs installed at the same time- they have a life expectancy of around 250-275K.
 

·
Registered
Joined
·
1 Posts
I just got a 92 w250 and when i put some load on it it smoked white abit. then i turned in the smoke screw a bit and i got a miss at higher rpms and white smoke.
 
1 - 17 of 17 Posts
Top