Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Cummins of the Month Challenge!
1 - 9 of 9 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
On the road, put 20 gallons of Shell diesel in, ran about 45 miles, can't get over 1500 rpm, engine sputtering and blowing white smoke. All guages indicate normal ranges, egt is normal, only thing abnormal is low boost percentages.
2005 Ram 2500 quadcab, 42000 miles, BD auxillary boost pump, Edge Juice, AEM Brute Force air intake, CFM intake, Silverline dual catback exhaust. Oil looks ok, no change in level in raditor overflow tank. Unable to check for water in fuel, no flash light and its dark out. Problem came on without any warning, everything was running great and then lost power. Any ideas out there?
What should I look for?
 

·
Cummins Fanatic
Joined
·
875 Posts
Start by changin your fuel filter. Theres really no way of tellin whether its plugged other than puttin a new one in and see if the problem goes away. Fuel filters are cheap so I would start there.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #3 ·
White smoke

Ok, fuel pressure is good, I drained some fuel from the water separator, looked clean, changed the fuel filter out (it didn't look that bad), running fine now. If is really wasn't the filter is it an indication that something else might be acting up?
 

·
Registered
Joined
·
4,830 Posts
sounds like a lift pump
 

·
Registered
Joined
·
4,830 Posts
sorry just saw that the FP was good.
 

·
Cummins Fanatic
Joined
·
875 Posts
Ok, fuel pressure is good, I drained some fuel from the water separator, looked clean, changed the fuel filter out (it didn't look that bad), running fine now. If is really wasn't the filter is it an indication that something else might be acting up?
I would guess that you got the problem taken care of. Often times you cannot tell if the fuel filter is bad just by looking at it. First thing I always do when I get low fuel pressure is CHANGE MY FUEL FILTER. Its a cheap fix and you're not out a whole lot of money if it would turn out to be something else.:thumbsup
 

·
Registered
Joined
·
49 Posts
had same issue w/ mine once and had a failing lift pump stock lp's go oout like bearings.. little by little g/luck
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #9 ·
Thanks to everyone that responded. Turns out I had triped an active code that put the truck in "limp mode", I must have cycled the key the right amount of times to clear the code at the same time I changed the fuel filter and that's why it started running fine.
 
1 - 9 of 9 Posts
Top