Dodge Cummins Diesel Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
430 Posts
Discussion Starter · #1 ·
Can't figure it out? This is What happens.

Truck in sig, nothing new.

Running Smarty on level Revo #5 when i i shift from 1st to 2nd and get on it going from a lower rpm to higher rpm the truck sputters and misses(like it not getting enough fuel, almost like its draining the rail) thru a small window of the rpm range then regains and takes off and runs nice and strong like it should. My fuel pressure is set at 20 psi and ranges from 16psi to 20psi, my rail pressure idles at about 5-7k and WOT its about 25-27k. I've tried the smarty on lower levels and it doesn't do it, but then again not as much fueling either. I haven't tried it on a higher level yet.

So far i have replaced the Pressure Relief valve with a new one and am getting ready to throw a new FCA in it in a little bit to see if that helps. Just thought i'd get more opinions of what you guys are thinking. Fuel filters were all just changed within last 500 miles.

I can't imagine it'd be draining the rail as the only thing thats really been done to truck is smarty and a turbo. I'm still running stock injectors and the Cp3 is still stock.
 

· Registered
Joined
·
1,424 Posts
Whats the rail pressure doing when it sputters?
 

· Registered
Joined
·
430 Posts
Discussion Starter · #3 ·
Rail pressure when starts sputtering is around 12-15 working it way up. And when it sputters it spits out little white smoke then clears up and turns to black like it getting fuel again. It only does it within a very small window of rpm range just below 2000 rpm
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top