Dodge Cummins Diesel Forum banner

1 - 20 of 407 Posts

·
Registered
Joined
·
8,740 Posts
Discussion Starter #1
Seeing as the interest is never ending for headlights, stock or aftermarket, I created this thread just for that.

Stock headlights (quad,projector)
Aftermarket (quad, projector)
TYC
MOPAR
AlphaRex
Simple upgrades
Extensive upgrades

If you’ve got questions, want to show off your latest upgrade, or just want a one stop shop for anything and everything headlights, this is your place.

We’ve needed a thread like this for a while now. Lots of guys are showing off their latest upgrades but unfortunately there’s so many threads it’s hard to keep up with whose done what.

Come one come all. This thread is for anyone and everyone.
 

·
Premium Member
Joined
·
1,565 Posts
Headlights are fun projects. Their cheap. Anyone can mod theirs without having to spend thousands.
I beg to differ. These things can get pricey. I hope to be done with them after this go around.

AlphaRex
Morimoto D2S projectors
Morimoto 35w ballast
Morimoto relay harness
Osram D2S
Morimoto HB LED (waiting on TRS to ship these)

Should’ve had all this stuff shipped to you.
 

·
Registered
Joined
·
56 Posts
My lower tabs on my headlights are missing. Anybody have a good way of making new tabs, I was thinking of just taking some sheet metal and screwing into the housing? Or should I try to make some out of plastic and plasticweld them to the housing.
 

·
Premium Member
Joined
·
1,565 Posts
I beg to differ. These things can get pricey. I hope to be done with them after this go around.

AlphaRex
Morimoto D2S projectors
Morimoto 35w ballast
Morimoto relay harness
Osram D2S
Morimoto HB LED (waiting on TRS to ship these)

Should’ve had all this stuff shipped to you.
Pics!!!
TRS says the 20th...but we’ll see how that goes.
 

·
Registered
Joined
·
259 Posts
I did the the TRS retrofit morimoto mini d2s projectors. Did this about 3 years ago. Huge night and day difference from stock.

However, wish I found a better shop. They deformed one of my housings. But since everything still sealed (for the most part) and functioned they would not replace it. I get condensation sometimes, mostly when the seasons first change. Another issue I have is I have to turn the lights on and off sometimes to get the passenger side to light up. Again this is mostly when it's cold outside. TRS was great in working with me to fix this issue and sent new ignitors but they didn't work as they were a different model or something. Mine had a orange housing and these were grey. Life got in the way and never persued it and just lived with having to turn them on and off sometimes.
Anyways, I also had them paint the interior black, I had the stock chrome lights. The shop did give a life time warranty on the work, so hopefully I'll never have to use that. Overall I'm extremely happy with the product from TRS and their customer service is top notch, just wish I found someone more OCD than my self to do the work. Wish I came across nick00less sooner. Was going to try to do it myself at first but was uneasy baking a brand new and expensive headlight.

If you are thinking of doing this upgrade it is definately worth it to be able to see at night. I rarely use the high beams and I live out in the country. The rigid led lights I have in the bumper help with that but I don't even use those that much that's how great these are.

Sent from my SM-G960U using Tapatalk
 

·
Registered
Joined
·
695 Posts
^I always recommend Lightwerkz in NJ - Caesar would not let subpar work out of his shop, have known him for years and hes top in the industry IMO

On your ballast sometimes not firing on one side - I would absolutely call TRS and utilize their warranty service - you probably have the older DSP ballasts which were not as reliable and sometimes one would strike - your ballasts might still be under warranty? Give it a shot - the XB 2.0 ballasts have come a LONG way for reliability vs. what I was using 5 years ago (the SS ballast which was a nightmare and then the DSP which was only marginally better)

Nick - great thread - I agree, its needed - especially for guys who may be troubleshooting since the advent of AlfaOBD and being able to do the "software fix" when hooking up HID's to our vehicles -
 

·
Registered
Joined
·
259 Posts
^I always recommend Lightwerkz in NJ - Caesar would not let subpar work out of his shop, have known him for years and hes top in the industry IMO

On your ballast sometimes not firing on one side - I would absolutely call TRS and utilize their warranty service - you probably have the older DSP ballasts which were not as reliable and sometimes one would strike - your ballasts might still be under warranty? Give it a shot - the XB 2.0 ballasts have come a LONG way for reliability vs. what I was using 5 years ago (the SS ballast which was a nightmare and then the DSP which was only marginally better)

Nick - great thread - I agree, its needed - especially for guys who may be troubleshooting since the advent of AlfaOBD and being able to do the "software fix" when hooking up HID's to our vehicles -
Thanks, I did look into him but I was living all the way out in long island at the time so it was not feasible to go to him or to send my lights out. I didnt have a second car at the time so needed to drive the truck. The shop ilI went to was highly recommended and had a great reputation and in the city, so it was easier to drop it off before work and pick it up after. Now I'm in orange county and could've definately gone to him and wish I did. I'll look into the warranty. They other issue I have and forgot to mention is I always get a prompt at start up that there is a headlight out. Never bothered to look into that either. But now this thread is making me add this to my long list of projects thanks. Haha

Sent from my SM-G960U using Tapatalk
 

·
Registered
Joined
·
94 Posts
Just basic retrofit since the output of stock Quads have to be some of hte worst of any headlight in production. Unreal ram can even get them past safety.

CNLight H1 Bulb
Mini H1 V7.0 Projector
Hylux 2A88 Canbus Ballast
Mini Gatling Gun Shroud

I did have one ballast fail other day when it finally got cold (about -20C). Replaced under warranty and no issues since.
 

Attachments

·
Registered
Joined
·
695 Posts
^^More details Richard! Are you running a relay harness with your Hylux ballasts?

Have you enabled HID setting using AlfaOBD?

Do you get any headlight errors, *EVER*?

They have a super low failure rate and I'm glad one was replaced under warranty and worked out.
 

·
Registered
Joined
·
94 Posts
No relay harness. Enabled hid / led in Alfa and that's it. No errors. I moved my DRLs to my signals so HIDs to flick on and off to much and siabled lights with wipers to also avoid unneeded on and off. No issues no errors
 

·
Rear Admiral Rickard Onmi
Joined
·
6,031 Posts
Quads have to be some of hte worst of any headlight in production. Unreal ram can even get them past safety.
The Quads were actually among the best lights Ram had offered throughout it's series of trucks. Compare lighting in a quad to any of the older trucks, whether it be duals in the 4th gen, or any 2nd and 3rd gen, or even the sealed beams in the first gens. The light output isn't as horrible as you think when compared to what came before it.


I will have some updates here soon, Nick knows some of them, but i didn't get around to any of it this weekend. Possibly tonight, but probably next weekend for more from me on upgrades
 

·
Registered
Joined
·
695 Posts
No relay harness. Enabled hid / led in Alfa and that's it. No errors. I moved my DRLs to my signals so HIDs to flick on and off to much and siabled lights with wipers to also avoid unneeded on and off. No issues no errors
Richard thanks - this may be very helpful to a few of us here -

Did you enable HID, *and* LED low beam in Alfa? Aka 2 settings?

Some of us get random errors when just turning on HID setting so I am curious if enabling the LED low beam setting as well may fix the remaining errors.
 

·
Rear Admiral Rickard Onmi
Joined
·
6,031 Posts
Also, as a side note, my understanding with Alpha is to always enable HID, regardless of running LED or HID. Enabling LED does not turn off PWM, while enabling HID does. I am not sure what all enabling LED does do, but it might turn off error codes while leaving PWM in tact, while enabling both could turn off all error codes and PWM? but that is just a guess. For the purpose of this thread i think it would be beneficial if people report all changed settings (related to lighting) they have done with Alpha, along with what they are running.
 

·
Registered
Joined
·
695 Posts
Agree completely and you are right - the HID setting was confirmed to turn PWM off -

However some guys still report random errors which tells me something else is going on- perhaps capacitors and/or Canbus adapters still are needed for some other function of the BCM that we don't know about?

Absolutely agree the guys that have flawless working setups need to share details of any additional relays, harnesses etc added, and what settings changed in Alfa.

I can't imagine using one ballast vs. the other (Hylux 2A88 vs. Morimoto XB35 with a Morimoto Canbus) would make the difference, but I've been wrong before. Hylux does have extra grounds on their ballasts so maybe those 2 minor features (integrated Canbus on the Hylux, extra ground cable on each ballast) would do something?

I also am theorizing for the guys that have errors maybe the BCM was updated in late 2018 on some models and now there is something else we are missing?

I am going to try to do some testing and see if the XB35 kit I have, works by itself with just changing Alfa setting to HID. If it doesn't, I will start by trying to add Canbus modules and potentially the relay in conjunction with the Canbus modules.
 

·
Premium Member
Joined
·
283 Posts
I am totally in on this thread!!!

Great idea Nick!
 
  • Like
Reactions: nick00less

·
Registered
Joined
·
94 Posts
Im running both LED and HID in Alfa. No issues not a single error not even once.

High Intensity Discharge Head Lamps: Set
LED Front Fog Lamps Present: Set

DONT set the Bi Xenon setting. This only enables an output on the BCM to control the shutter in a projector. Requires running an extra wire from BCM to headlights. Mine are just tapped of the high beam inside the light to trigger the shutter in the projector. Less wiring and no programming involved then for the same result. If you were running no high beam bulb and just using the projector you would need to set this function and run the wire.

Im not running any relay harness but my HIDs do have the built in canbus adapters.

I am also running the morimoto fogs with no harness. Just plug straight in. I did have to trim the connectors a little but to get them to fit but that was it.
 

·
Registered
Joined
·
6,158 Posts
Seeing as the interest is never ending for headlights, stock or aftermarket, I created this thread just for that.

Stock headlights (quad,projector)
Aftermarket (quad, projector)
TYC
MOPAR
AlphaRex
Simple upgrades
Extensive upgrades

If you’ve got questions, want to show off your latest upgrade, or just want a one stop shop for anything and everything headlights, this is your place.

We’ve needed a thread like this for a while now. Lots of guys are showing off their latest upgrades but unfortunately there’s so many threads it’s hard to keep up with whose done what.

Come one come all. This thread is for anyone and everyone.
Nothing.
 
1 - 20 of 407 Posts
Top