Dodge Cummins Diesel Forum banner

Weird RP happenings

607 Views 6 Replies 3 Participants Last post by  turborep
Today I was cruising along at 70mph and looked down and my RP was bouncing between 20 and 21K. I turned off the cruise and slowed down and the RP dropped but when I got back up to 70 it went right back up. I was running the RP on the smarty at 3 at the time so I loaded it to stock and went back out, kicked it up to 70 and the RP was right back to where it usually is. Loaded RP 3 back into it and it is fine now. What could be wrong? The truck was running fine, it was empty and had the cruise set. If it wasn't for the guage I wouldnt have known there was a problem. Anybody else ever see anything like this?
1 - 7 of 7 Posts

· Registered
Joined
·
4,004 Posts
is it there new model or older model..if its the older one there known to have problems, get rid of it.if its the new one, call quad.
 

· Registered
Joined
·
622 Posts
Today I was cruising along at 70mph and looked down and my RP was bouncing between 20 and 21K. I turned off the cruise and slowed down and the RP dropped but when I got back up to 70 it went right back up. I was running the RP on the smarty at 3 at the time so I loaded it to stock and went back out, kicked it up to 70 and the RP was right back to where it usually is. Loaded RP 3 back into it and it is fine now. What could be wrong? The truck was running fine, it was empty and had the cruise set. If it wasn't for the guage I wouldnt have known there was a problem. Anybody else ever see anything like this?
What do you mean by "fine" RP?
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top