Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
1,258 Posts
Discussion Starter #1
My 01 had a sudden drop in lift pump pressure just before the last injection pump died.

Now the pressure problem has returned, maybe 11 psi at idle, 7 - 8 cruising, and 4 to 5 at WOT. I tested the lift pump, and it ran to 17 psi aganst a dead head and opened its relief valve.

Is there some mechanical failure in the VP that will cause this? Replacement IP is about 3 months old.

Any help would be appreciated.

Ops
 

·
Registered
Joined
·
1,258 Posts
Discussion Starter #3
Well, it looks like it may be the overflow valve acting up again, I hve one on the way. I'll post once I install it..

Ops
 

·
Registered
Joined
·
121 Posts
put an upgrade lift pump or a (in tank mount run that to your holly the to the vp thatll work
 

·
Registered
Joined
·
14,896 Posts
Ops, you'll see that I posted the same problem today. I came to a stop and my FP was about 8 where its usually up around 15 at idle. After a few minutes of idling it came back up and everything was fine but I threw the P 1693 code. Most likely for low FP. Now I dont know if my LP thats never given me an ounce of trouble is going or not. I'm thinkin of getting another for a back up incase that happens again but I really want to make sure its the LP that has the problem. Read this VP44 DIAGNOSTIC HELP
 
1 - 5 of 5 Posts
Top