Dodge Cummins Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2000 AT. I was just pulling a small single axle trailer with a maybe 300lbs mower. Going up a not so steep hill the water temp went way up. Truck runs at around 190 but jumped to the red. I have a new thermostat and flushed the fluids.

Any ideas Thanks
 

·
Premium Member
Joined
·
19,886 Posts
i would first check the fan clutch and also check the thermostat. also fill out your signature so we know what you have. is the truck stock???
 

·
Registered
Joined
·
275 Posts
also check and see if the radiator is plugged on the outside. those 24valvers are known for collecting dirt in the fins of the radiator and not letting any air through
 

·
Premium Member
Joined
·
19,886 Posts
I have a 2000 AT. I was just pulling a small single axle trailer with a maybe 300lbs mower. Going up a not so steep hill the water temp went way up. Truck runs at around 190 but jumped to the red. I have a new thermostat and flushed the fluids.

Any ideas Thanks
:doh: :doh: :doh: :doh: didn't read that the first time
 

·
Registered
Joined
·
623 Posts
your radiator is gunked up from the blow-by tube:doh: you will never get it clean enough with it in the truck, gonna have to pull it and soak it in degreaser:thumbsup: then re-route your blow tube so it doesnt happen again:headbang:
 

·
Mopar1973Man.Com
Joined
·
26,302 Posts
your radiator is gunked up from the blow-by tube:doh: you will never get it clean enough with it in the truck, gonna have to pull it and soak it in degreaser:thumbsup: then re-route your blow tube so it doesnt happen again:headbang:
Which is a good bet... Now talk a look here...
Crancase Vent
 
1 - 6 of 6 Posts
Top