Dodge Cummins Diesel Forum banner

1 - 20 of 35 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter #1
so i have been searching and found a lot of information about cold starts producing white smoke but not anything about warm starts. my trucks starts great in the mornings cold starts just fine no noticable smoke but if i have been driving it for a few minutes and it is up to warm operating temperature when i shut it off for 5-15 min and restart it I get white smoke for a good 10-15 seconds then it thins out and goes away. the truck is never hard to start when it smokes and seems to be fine on power.. any ideas as to what would cause the bad smoke? it is an 08 6.7 with egr unplugged, dpf delete and a 5"tbe with xrt pro on the mild setting. 45k miles. temperature outside is about 40*
 

·
Registered
Joined
·
894 Posts
egr cooler needs to be deleted
 

·
Registered
Joined
·
113 Posts
Discussion Starter #3
I have read that this could be a possible culprit does it just let coolant seep into the exhaust or what? I was planning on doing the full delete as soon as i have the money anyway so hopefully that will take care of it..
 

·
Registered
Joined
·
894 Posts
I'm not sure what's happening but I know a full delete fixed it for me.
 

·
Registered
Joined
·
304 Posts
An egr and cooler delete is like $90, or you could burn that in coolant.
 

·
Registered
Joined
·
113 Posts
Discussion Starter #6
yea i just ordered one so hopefully that is the problem
 

·
Registered
Joined
·
2,795 Posts
I agree about the cooler. I was getting a hazing at start up and while idleing. Chased it to the EGR cooler. When I went to delete the cooler and pulled off the cross over pipe, i had coolant mixed with condensation. I tasted it and it was sweet just like coolant. EGR cooler was cracked!!! So, Off came the cooler and on went the blocker plates. Now here is the kicker..........Mine is a 2010 with 3k on the dial. After that little delete........So far so good!!!!!
 

·
Registered
Joined
·
113 Posts
Discussion Starter #8
well while i wait for my egr delete kit to come in I have a small update.. i for the first time got a lot of smoke on a cold start.. dont know if that has any effect on weather its the cooler or not.. it seems to be doing it worse now almost every time i start the truck. the coolant level seems to be fine, i havnt noticed it drop any. i started to wonder if it is a bad injector checked my oil for any diesel smell couldnt really tell.. oil level was a little high but i have not changed the oil since i purchased the truck a couple weeks ago so it may have been high already.. i am really praying its the egr cooler. in the mean time while i wait on the kit can i unplug the egr cooler? would that do any good at all? or should i just not mess with it?
 

·
Registered
Joined
·
894 Posts
You can't unplug the cooler. You have done what you can till the delete kit shows up. I'm about 95% the cooler is the prob. I went thru the exact same thing.
 

·
Registered
Joined
·
113 Posts
Discussion Starter #10
well i just instaled the egr delete and cooler delete and now the truck runs like complete crap.. i followed the instructions everything is done right.. i tried reinstalling the tun with my xrt pro it starts up and idles very rough shaking the whole truck and puffes out a lot of white smoke pretty much as long as it is running.. any ideas???
 

·
Registered
Joined
·
113 Posts
Discussion Starter #11
also noticed that it bucks pretty bad when accellorating and there is no power when i try to accellerate its like it is being choked out it wants to but cant.. i dont really know how to explain it.. the rpm wont go over about 1500..
 

·
Registered
Joined
·
2,795 Posts
Did you unplug the throttle valve on the intake horn???????

Sounds like the valve is closing trying to use the egr and is choking out the truck.
 

·
Registered
Joined
·
61 Posts
Only thing I can think of is reload factory tune, then reload XRT, check/change the crank case vent filter if you are over 65K miles. Check it anyways for oil stauration. White smoke is coolant or oil...if it's coolant could be head gasket,,, very coommon on this board. TV is disabled by XRT, but wouldn't hurt to delete the gear in it.
 

·
Registered
Joined
·
894 Posts
Remove butterfly valve??
 

·
Registered
Joined
·
113 Posts
Discussion Starter #15
i havnt removed he butterfly valve but it is unplugged.. do i need to remove it? everything was running fine this morning other than the puff of white smoke on start but as soon as i did the egr and cooler delete it kinda went to crap..
 

·
Registered
Joined
·
894 Posts
i havnt removed he butterfly valve but it is unplugged.. do i need to remove it? everything was running fine this morning other than the puff of white smoke on start but as soon as i did the egr and cooler delete it kinda went to crap..
Yes I do believe it needs to come out. I had to take mine out.
 

·
Registered
Joined
·
894 Posts
Also, I did not remove the gear. I would remove the valve , it's super easy. Just work the brass screws out.
 

·
Registered
Joined
·
113 Posts
Discussion Starter #19
so i have a new update.. it seems like it has stopped smoking on start ups which is good but now i get smoke at random times.. it seems like after i have been driving about 15 min and the truck is fully warmed up it lets out a big puff of white smoke for about 15-30 seconds then it completely stops.. there is no loss of power or change in how the truck is running.. just big puff of smoke then everything is fine..
 

·
Registered
Joined
·
894 Posts
Did you delete the cooler and butterfly valve yet? Not sure if the butterfly is nessasary with the BM/xrt pro or not but I had an edge before so I had too. The cooler is a big one, in my opinion. If it's still there it's most likely the problem. A block off plate is not a delete remember. It still has coolant running thru it.
 
1 - 20 of 35 Posts
Top