Dodge Cummins Diesel Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
181 Posts
Discussion Starter #1
Hey guys I think maybe my VP is toast.
I pulled my 01 engine out cause' of a cracked block,put a 2000 engine in,so it's the SO,had to replace the LP,the previous owner had no idea that it could go out.....who knows how long it ran on a bad LP with some kinda box (had a nick in the pump wire)Soooo anyway nuff' background.

Started the thing up to get hooked up to a trailer yesterday and if fired up just fine,let it tick over a couple of seconds then pulled forward about 30' pulled it out of gear,and it almost died,running like it does when you first bleed em and they are running on 1-2 cylinders.
I shut it off,hard to get it restarted,it did finally restart and ran awfull still,good LP pressure,I've got a gauge.
I don't have a way to check codes,so I don't know if it has any,my wife had a baby the other day and I was sick of stuff like this,so I borrowed a PSD and headed back to the house (320mi).
 

·
Premium Member
Joined
·
5,820 Posts
Manual and Automatic VP's have different computer stuff on them. you could have issues with the ECM being compatable with the VP from an Auto.

If you buy a reman, get the HO pump that should be in the truck or run the numbers off your old pump.

If you need a hand give us a call
 

·
Registered
Joined
·
80 Posts
to check the codes flip the ignition switch on and off 3 times pretty quickly leaving it on the 3rd time. you may have to try it a couple of times for it to work but it will i promise. i've done it on mine many times.
 

·
Registered
Joined
·
181 Posts
Discussion Starter #4
Manual and Automatic VP's have different computer stuff on them. you could have issues with the ECM being compatable with the VP from an Auto.

If you buy a reman, get the HO pump that should be in the truck or run the numbers off your old pump.

If you need a hand give us a call
It was in a 2000 with a 6 speed,so the ecm is right for the engine (2000=no HO)
I have the VP off of my old engine,it's a "HO" pump,I'm thinking it will work on this engine also,but I'm not quite 100% on that,I know ppl put the SO on the HO engine to get more top end power,but I don't know if a 01 HO VP will work on a 2000 SO engine.
 

·
Registered
Joined
·
181 Posts
Discussion Starter #5 (Edited)
Yeah shoulda tryed that

to check the codes flip the ignition switch on and off 3 times pretty quickly leaving it on the 3rd time. you may have to try it a couple of times for it to work but it will i promise. i've done it on mine many times.
I know it,should have tryed it,but I would not know if the problem was new or something from before anyway.

Thank you both for your responses,the truck is 320 miles from me at the moment,so I'm trying to figure out what to do before I drive back to it:CRY:

I did notice that the power was down a little too,still pulling good,just the boost numbers were down from 32psi to around 28psi(before it broke),so I'm leaning towards the VP,but I'd hate to make a big ol' mistake!
 

·
Registered
Joined
·
181 Posts
Discussion Starter #6
Anyone have this problem? At least anyone know if I'd be waisting my time to put the spare VP off my old 01 HO engine on my 2000 SO engine?
 

·
Registered
Joined
·
293 Posts
usually a vp44 would just stop working completely.. thats what i thought anyway.. it might just be air bound some how..try cracking the lines to make there is no air in the fuel system.
 

·
Registered
Joined
·
181 Posts
Discussion Starter #8
usually a vp44 would just stop working completely.. thats what i thought anyway.. it might just be air bound some how..try cracking the lines to make there is no air in the fuel system.
I thought so too,I can't really check it till monday,it's over in Portland OR,thats about 320miles away,so I'll check that when I get there,although I can't imagine how that could have happened,I'd just got done driving it a few hundred miles,shut it off and talked to the boss,then started it and it ran good,then died...strange.

You all think that I can get away with putting my 01 HO VP on the 2000 SO engine I have in my truck now?
 

·
Registered
Joined
·
181 Posts
Discussion Starter #9
Since no1 here seemed to know,I've been told that the HO pump on a SO engine is a no-go
 

·
Ontario Chapter President
Joined
·
2,496 Posts
Give bleeding the lines a try as suggested, that just might do it?

Its got some pretty weird symptoms tho....keep us posted. :thumbsup

I'd PM Gus aka farmboysdiesel to find out for sure, He'd gladly talk to ya about possible causes and maybe some fixes PLUS he's one of our vendors here on CF. He's a very knowledgeable VP guy.
 

·
Registered
Joined
·
181 Posts
Discussion Starter #11
I'll let you know for sure,I will try bleeding them,I can't imagine how it got air in it,but trying is free,I'll check my darn sending unit too,just in case.....
Thanks to all who have tried to figure this out,I know there were a bunch of you that just did not post.
 

·
Mopar1973Man.Com
Joined
·
26,292 Posts
Ah I found your thread...:rof

You know I got the re-prime instructions over on my site...

But you might try the fuel pump diagnostics and see if there is air bubbles in the fuel supply... If so there is your problem...:w:
 

·
Registered
Joined
·
181 Posts
Discussion Starter #13
Haha Mopar1973man...why would I need to re-prime a truck with a full tank of fuel and 15psi at the vp inlet?
I've primed a couple,changed a couple too.
 

·
Mopar1973Man.Com
Joined
·
26,292 Posts
Just like me yesterday... I've got 17 PSI of fuel pressure but lots of foam and air bubbles beacuse I'm really low on fuel. I had to prime it twice... :rof

I just installed the Draw Straw Kit... I've got 7 gallons of fuel in the tank but I was still having troubles getting the trapped air out of the system till I fill up with fuel...:w:





 

·
Registered
Joined
·
181 Posts
Discussion Starter #15
I got at least 25gallons in mine,it's reading on the full line....
I'm going to check and make sure that I'm getting clear fuel without bubbles when I get her back,gotta haul it clear back from Portland :(
 

·
Registered
Joined
·
181 Posts
Discussion Starter #16
1688 bro,be changing a VP this week.
 

·
Registered
Joined
·
181 Posts
Discussion Starter #17
VP changed,runs great!
 
1 - 17 of 17 Posts
Top