Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
242 Posts
Discussion Starter · #1 ·
im charging plenty but the meter wiggles until i give it some gas. new voltage regulator. someone told me these 1st gens do it alot.
 

·
First Generation Moderator
Joined
·
2,170 Posts
You have an external reg? They will. You need to ground the regulator better.
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #3 ·
yeah it is external. ill take a dremel to the body where it mounts, thanks!
 

·
Registered
Joined
·
1,154 Posts
You have to run a wire from the base of the regulator directly to the neg terminal on the battery. The cab or body ground is not that good for some reason. that should fix issue.
 

·
First Generation Moderator
Joined
·
2,170 Posts
What I did was to make a jumper w/solered connections. It is connected to a corner of the reg and to the body. Then, I cleaned the battery neg cable at the engine and then made a new, heavy duty ground wire (#10 AWG) with solered connections from the bat neg post to the rad support.

That fixed my wiggle and likely any other furture issues. A gound wire from the reg to the battery would be another quality repair.
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #6 ·
What I did was to make a jumper w/solered connections. It is connected to a corner of the reg and to the body. Then, I cleaned the battery neg cable at the engine and then made a new, heavy duty ground wire (#10 AWG) with solered connections from the bat neg post to the rad support.

That fixed my wiggle and likely any other furture issues. A gound wire from the reg to the battery would be another quality repair.
thanks, i fixed the problem
 
1 - 6 of 6 Posts
Top