Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 13 of 13 Posts

·
Registered
Joined
·
543 Posts
nice wat did you run it in i couldn't see
 

·
Registered
Joined
·
3,669 Posts
Discussion Starter · #4 ·
spun on launch so only turned 13.56 at 99+ mph
 

·
Registered
Joined
·
993 Posts
definitly killed him off the line. Nice job!!
 

·
Registered
Joined
·
3,669 Posts
Discussion Starter · #6 ·
(Looking at your sig) You don't have an aftermarket turbo????
no sir. for your next question 44 psi and 1450 on the top side.
 

·
Registered
Joined
·
3,669 Posts
Discussion Starter · #9 ·
some one would have LOL and thanks for the complements!
 

·
Registered
Joined
·
1,256 Posts
If you hadn't stomped him on the light... but that's another story, about a driver that could have handled the goat.

4wd launch? wonder what that truck would do with an aftermarket turbo.... can't wait to see whats next, nice rig.
 

·
Registered
Joined
·
3,669 Posts
Discussion Starter · #12 ·
If you hadn't stomped him on the light... but that's another story, about a driver that could have handled the goat.

4wd launch? wonder what that truck would do with an aftermarket turbo.... can't wait to see whats next, nice rig.
actually I was beating him ET wise all night. I run 8.5 to the 1/8.

4wd 14 psi launch and I have plans to get it a bit faster before the turbo(s).:peelout
 

·
Registered
Joined
·
1,220 Posts
:thumbsup Nice Run :thumbsup
 
1 - 13 of 13 Posts
Top