Dodge Cummins Diesel Forum banner
1 - 19 of 19 Posts

· Registered
Joined
·
88 Posts
Discussion Starter · #1 ·
I just installed the industrial injection twin setup where you keep your stock turbo. I also installed their waste gate. I am wondering what a safe/efficient drive pressure is? When I got WOT up to about 90mph the dp will hit about 70. Any help would be appreciated. Thanks
 

· Registered
Joined
·
569 Posts
What was your boost with 70lbs of drive?!
 

· Registered
Joined
·
88 Posts
Discussion Starter · #3 ·
I'm not sure since the factory map sensor only shows up to 38psi but the guys at industrial injection said I should be around 50 psi of boost
 

· Registered
Joined
·
506 Posts
Most people recommend getting DP close to Boost pressure. If it's a little more than 1:1 that's ok.

Now if you are close to 70 psi of boost on that kit ( I doubt, Industrial is prob close on their guess)), you can create a lot of cylinder pressure at low rpms.

Watch not only drive pressure but cylinder pressure at low rpms, i.e. hard fueling and high boost down low. With good rods it can take a lot more pressure.
 

· Registered
Joined
·
88 Posts
Discussion Starter · #5 ·
They said 50 psi boost is probably what I'm running with stock injectors. My drive pressure is almost 70 on a hard wot run. I'm having trouble getting my ratio to 1:1 without having much turbo lag at lower rpms.

Should the boost/dp be close to 1:1 during acceleration? Mine seems to be 1:1.5 while accelerating then levels out. How would you monitor cylinder pressure?
 

· Registered
Joined
·
506 Posts
I can see them being right.

less fuel equals less boost, so turn down the programmer, which will unfortunately make it less responsive.

EFI live would be the best way to tune bc you can tailor the fuel curve to your needs (per RPM)

You can't monitor cylinder pressure but if you fuel hard and have good boost at low rpm, you will have high cyl pressure. Some people bring the fuel in between 22-2500 rpm to help with this.

The other guy in this post has the same kit and has not blown anything up that I know. Others have had some trouble. Sometimes the person does stupid stuff though, so not always the kits fault.

I think with studs and good rods the kit could be ok. Only thing left that concerns me is the small stock exhaust housing.
 

· Registered
Joined
·
88 Posts
Discussion Starter · #7 ·
So is it just high drive pressure that's bad or is it a lopsided ratio that's bad? For example if I were building 50psi dp with 10psi boost would that be worse than building 50psi dp and 50 psi boost?
 

· Registered
Joined
·
569 Posts
Just experiment with it, mine runs a better ratio on hotter tunes. Its going to be merely impossible to get a 1:1 ratio throughout the full rpm range. Ive always kept mine close to1:1at wot, easy driving can hit close to 2:1.
 

· Registered
Joined
·
88 Posts
Discussion Starter · #13 ·

· Registered
Joined
·
88 Posts
Discussion Starter · #14 ·
I don't think I'm very far off from 1:1. It just seems to be hard to set it up to keep low end responsiveness and not have high dp. Also my exhaust brake seems to work better when I set the waste gate tighter. Right now I have both the heavier springs and larger valve seat installed, preload tightened all the way, and just one boost line in the top port.
 

· Registered
Joined
·
3,180 Posts
Just got this kit on my dads 5500 along with a fully built motor. I will see what we get her to with efi by Ryan . Kit also has ii wastegate which looks like a kid welded it and didn't even have the flange ports cut open! Also re did some of the piping. But any how it will be ran with efi by Ryan , 75 GDP nozzles with balanced flowed injectors, air boss, GDP horn, stage 3 billet colt cam, 12, rods polished and cyro treated with 110lb valve springs and push rods banks intercooler and batmo wheel vgt .... Should be a stout pulling rig. Will post results when she runs ... Sticking stock cp3 for now but fed by fass 200. Wicked pump or arson in future if need it.


Sent from my iPhone using AutoGuide.com App
 

· Registered
Joined
·
72 Posts
No waste gate. I haven't done much testing to see if it will be needed or not
 

· Registered
Joined
·
88 Posts
Discussion Starter · #17 ·
No waste gate. I haven't done much testing to see if it will be needed or not
If your running a 1:1 ratio I wouldn't think you would need one. What tune are you running on your black maxx?
 

· Registered
Joined
·
72 Posts
Can't remember off hand, away working but it does have the + boost, and its been awhile since I did an update. Can't run on the hot setting due to EGT's need intercooler.


Sent from my iPhone using AutoGuide.com Free App
 

· Registered
Joined
·
88 Posts
Discussion Starter · #19 ·
i have it set pretty close to 1:1 now and its runnning pretty well. i was driving the other day and went to pass a semi so i floored it in 6th gear and i heard kind of a shuttering sound under the hood. almost like a popping noise. i was wondering if it was the waste gate? has anyone else ever heard this?
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top