Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 20 of 25 Posts

·
Registered
Joined
·
831 Posts
Discussion Starter · #1 ·
I am haveing trouble spooling my twins i am only getting about 33-35psi after the top turbo spools then about 2 seconds later it will go on up to 48 when the bottom turbo starts to spool. the bottom turbo is only making about 18psi is there any thing i can reduce the lag between the two turbo or do i just need to fuel harder after i have like 20 psi of boost
 

·
Premium Member
Joined
·
5,818 Posts
I'd call PRD, they understand the setup and should be able to trouble shoot better than a stranger. Do you have an external wastegate? there are lots of variables and we need to know what you have to help
 

·
Registered
Joined
·
831 Posts
Discussion Starter · #3 ·
i have no external wastegate, top turbo is a s300 62/71/14 bottom is ht3b with a 26cm2 housing on it
 

·
Premium Member
Joined
·
5,818 Posts
reduce the waste gate pressure to approx 20-23 psi, this should make a smoother transition. The internal wastegate on the 14CM Cast housing may not be efficient enough
 

·
Registered
Joined
·
831 Posts
Discussion Starter · #5 ·
well i dont have a ajustable rod on the acuator how should i go about reducing the setting
 

·
Premium Member
Joined
·
5,818 Posts
You need to get us some pictures of the wastgate and the actuator or call PDR and get their assistance.... There are lots of options out there and giving advice on something I am not sure of is just out of line.
 

·
TECH SPECIALIST
Joined
·
1,793 Posts
i have a 62/71/13 over S480 and like jack says at about 20 psi they start working together and holy hell you'd better be holding on.. My kit is an MPI kit and has an actual spring you can adjust the wastegate so you can tune the turbos.. took my a day or two of tuning to get em close still need a little tweaking though... i've ran er up to 65 psi and scared the chit out of me once my head studs go in next friday here come DADDY!!!:beer
 

·
Registered
Joined
·
3,026 Posts
I used a s300 on top and changed the wast gate rod, I all so welded a freeze plug on the plate over a hole so it could open up farther heres the pic
 

·
Go for Broke
Joined
·
6,699 Posts
i have a 62/71/13 over S480 and like jack says at about 20 psi they start working together and holy hell you'd better be holding on.. My kit is an MPI kit and has an actual spring you can adjust the wastegate so you can tune the turbos.. took my a day or two of tuning to get em close still need a little tweaking though... i've ran er up to 65 psi and scared the chit out of me once my head studs go in next friday here come DADDY!!!:beer
i bet that set-up is good for 80+psi and still retain 1:1 drive pressures :thumbsup
 

·
Go for Broke
Joined
·
6,699 Posts
i have no external wastegate, top turbo is a s300 62/71/14 bottom is ht3b with a 26cm2 housing on it
the 14 housing may be hurting you a little.....harder to spool
 

·
Registered
Joined
·
831 Posts
Discussion Starter · #12 ·
so do i need to get a ajustable rod on the top turbo and then try lowering it down to like 20 or so
 

·
Premium Member
Joined
·
25,253 Posts
I would say your going to need some fuel as well. Being you have an 03 without injectors or a modded cp3, I'd say your light on fuel and heavy on the air the way it is now.



Dodge | Commins | Forum
 

·
Go for Broke
Joined
·
6,699 Posts
I would say your going to need some fuel as well. Being you have an 03 without injectors or a modded cp3, I'd say your light on fuel and heavy on the air the way it is now.
I agree :thumbsup
 

·
Registered
Joined
·
831 Posts
Discussion Starter · #15 ·
I would rather be heavy on air then fuel never got to let out if i dont want to
 

·
Registered
Joined
·
2,308 Posts
U guys make me so jealous!!!! Makes me wanna get a 2500 4x4 and dump 15 g's into it and have that holy cow hold on feeling. But then again, ur prolly only a 12 second truck and thats not fast. Well, its fast in a big truck like you guys have. Maybe 1 day for me. Other then that, nice info and have fun
 

·
TECH SPECIALIST
Joined
·
1,793 Posts
I agree :thumbsup
X3!!!!!!!!!


U guys make me so jealous!!!! Makes me wanna get a 2500 4x4 and dump 15 g's into it and have that holy cow hold on feeling. But then again, ur prolly only a 12 second truck and thats not fast. Well, its fast in a big truck like you guys have. Maybe 1 day for me. Other then that, nice info and have fun


15g's ithat's a good start...:thud::$::CRY::thumbsup
 

·
TECH SPECIALIST
Joined
·
1,793 Posts
i bet that set-up is good for 80+psi and still retain 1:1 drive pressures :thumbsup
Yes sir.... 65's the max i've taken it up to mainly because i have pictures of my head gasket blowing through the hood!!:lol3: So when the arp's are holding strong I will let'r rip!!!:woot:
 

·
Premium Member
Joined
·
3,113 Posts
Yes sir.... 65's the max i've taken it up to mainly because i have pictures of my head gasket blowing through the hood!!:lol3: So when the arp's are holding strong I will let'r rip!!!:woot:


You may want to still gate it around 65, JMO. I know a certain someone who has a decked head, studs, and kept bumping it up 65/70/75 and somewhere between 75-82 or so boom. And Im talking 3" piece of gasket blew out :rof, hey if your gonna blow it might as well blow the heck out of it so its easy to figure out.
I keep mine around 65 and can see spikes to 70, but Im sure I will be ringing it sooner than later :thumbsup. Again JMO.
 

·
Go for Broke
Joined
·
6,699 Posts
I would rather be heavy on air then fuel never got to let out if i dont want to
you need fuel to light the turbos and to make power......it won't run hot with that set-up.
 
1 - 20 of 25 Posts
Top