Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Cummins of the Month Challenge!
1 - 19 of 19 Posts

·
Registered
Joined
·
601 Posts
Discussion Starter · #1 ·
Looking for some input. I purchased a Shift Strategy unit from TS Perfromance and installed it with the aid of instructions and TS installation rep (via phone). It didnt work. Truck stayed in first gear and threw a problem code (transmission shift). The TS install. rep. told me to send it in.

I got it back a week later and was told it was shorted, make sure the power wire is +5 volts. I checked the power wire according the the instructions and TS rep. and it came back +5v. So I went ahead and installed it once more. Same thing, truck stays in first gear and has a engine check light.

Has anyone successfully installed this unit?
Or has anyone have similar problems and fixed?
 

·
Registered
Joined
·
1,063 Posts
I just purchased one and am going to install it in the next couple of days will let you know how it goes. Did you notice any improvements with your boost fooler? I didn't
 

·
Registered
Joined
·
601 Posts
Discussion Starter · #3 ·
I just purchased one and am going to install it in the next couple of days will let you know how it goes. Did you notice any improvements with your boost fooler? I didn't
Yes definitly keep me updated on the shift master. As far as the boost fooler I am not for sure, I dont have a boost gauge but I will be throwing the truck on a dyno next weekend so I will know by then. I hear it does really work though.
 

·
Registered
Joined
·
1,063 Posts
I Hooked Up The Ts And It Made No Difference! I Double Checked All Wires And Everything And Everything Is Hooked Up Right. So Either Its Junk Of They Sent Me A Broke One! Also The Boost Fooler Did Nothing I Am Running 32 Pounds Of Boost With And Without The Boost.
 

·
Registered
Joined
·
305 Posts
If I remember correctly (at least with the TS Shiftmaster) there was an issue with at least some of the 06 trucks. They don't have a +5v power down at the transmission.

They have probably redone the wiring for it by now, but the first ones that came out you had to steal power from the +5v at the MAP sensor. Have you called them to troubleshoot? I'm sure they will get it lined out.
 

·
Registered
Joined
·
305 Posts
I Hooked Up The Ts And It Made No Difference! I Double Checked All Wires And Everything And Everything Is Hooked Up Right. So Either Its Junk Of They Sent Me A Broke One! Also The Boost Fooler Did Nothing I Am Running 32 Pounds Of Boost With And Without The Boost.
Do you have any additional fueling to get you the extra boost? That may be why the boost fooler isn't doing anything. Might have to have a load behind that truck to get it to go higher on stock fueling.

As far as it not being noticeable, it's definitely noticeable. They can be a little bit of a pain to get wired up properly. I didn't do mine, since I had a wiring expert buddy of mine around to handle it. I am not good with wiring so I leave those kind of things to the pros.
 

·
Registered
Joined
·
1,063 Posts
i haven't called them yet when i finished installing it yesterday ts was already closed maybe i need to wire it to get more volts like you were saying but wired it directly like the directions said i had my buddy who does wiring for electronic controls for a living and we double checked the wires with a meter and everything. I guess i can check to see wat kinda volts its getting maybe its not getting enough voltage to power it. And i do not have any extra fueling but i figured i'd at least see a few pounds more boost!
 

·
Registered
Joined
·
601 Posts
Discussion Starter · #8 ·
I checked it per the instruction manual and the TS Performance tech. and it is +5 volts. I am trying to get some more answers from TS now. I wonder how many times I can send this thing in for repair before either they tell me to F off or I just give up.

As far as the Boost Fooler goes, even if you don't have a tuner there should still be a difference in boost levels as it doesn't open the wastegate as soon. You will see a even bigger difference once you do get a tuner though. I know I can hear a difference at high speed/RPM, the turbo continues to spool.
 

·
Registered
Joined
·
1,063 Posts
ya i have a ppe tuner so i wonder if it already has a boost fooler built into it? and ya ts so far is a thumbs down the web page says three settings when its just a lil knob you twist they also made it sound like a programmer should;ve spent the money on a copiolet
 

·
Registered
Joined
·
601 Posts
Discussion Starter · #10 ·
ya i have a ppe tuner so i wonder if it already has a boost fooler built into it? and ya ts so far is a thumbs down the web page says three settings when its just a lil knob you twist they also made it sound like a programmer should;ve spent the money on a copiolet
In dummy proof terms, can someone breakdown the Torque Converter Lock-up modules? How they work and what is the purpose.
 

·
Registered
Joined
·
601 Posts
Discussion Starter · #11 ·
Morning Bump.
 

·
Registered
Joined
·
121 Posts
I've had nothing but good luck from my shift master, no real change from level to level but it cures any shuttle shifting from 2-3. Happy with the purchase.
 

·
Registered
Joined
·
601 Posts
Discussion Starter · #13 ·
I've had nothing but good luck from my shift master, no real change from level to level but it cures any shuttle shifting from 2-3. Happy with the purchase.
How did you install your module and harness? Any pictures?
 

·
Registered
Joined
·
601 Posts
Discussion Starter · #14 ·
Anyone else on the Shiftmaster?
 

·
Registered
Joined
·
601 Posts
Discussion Starter · #15 ·
Anything else on the TS Shiftmaster? Anybody?
 

·
Registered
Joined
·
52 Posts
Attemtping to install the shiftmaster, Green wire fell out of the harness. Anybody know how to get the pins out of the harness? Any pics of where exactly the wires hook to? I have a 06' I don't understand why the red & black wires from the harnes are short.
Thanku in advance.
 

·
Registered
Joined
·
332 Posts
i have heard that the shift master was the best thing since the invention of the wheel. however i have also read things like they dont work and also have problems with diff. year model trucks. i recently put in a gorend trans and was considering the TS to get rid of the "hunt for shifts". now im not sure what im going to do. gorend offers their own sort of shift master thing so to speak, so im prob. gonna go with that b/c dave there has awesome customer service. i went to the TS outlaw event last night and just tried to speak with a rep.(from ts) and im not sure iv i even want to talk to them after how rude they were. im not try'n to bash too much, but poor customer service and too many probs with the shift master.:confused013: i guess you could get something elts. sorry bout the length of my rant.
 

·
Registered
Joined
·
601 Posts
Discussion Starter · #18 ·
I have had really good luck with their customer service. I have sent the shiftmaster in 2 times for repair and have had no issues it was 100% paid for by TS and received all new parts both times. Also the turn around was within the week. I plan on attempting to put the thing back on for try #3 this week.
 

·
Registered
Joined
·
1 Posts
I installed the shift master about a year or so ago. I had the shuttle shift and it cured it for a while. Finally went and had the dealership fix sensor in tranny, so it is a temporary fix that will soon start to show again. As far as installing it, the only problem I had was with getting a 5volt wire and I called them. They walked me through it after transferring me to one of their techs, had me hook to one of the MAP sensor wires. The guy I talked to seemed to be pleased to be helping me, I guess it is in who you talk to.

On performance, low setting seems almost as bad as stock shifting in that it wants to shift out of 2nd almost immediately. Middle setting, which I use all of the time, holds 1st until about 12-15 mph and 2nd till about 22-25 mph. High holds a touch longer in gears, but when coming to a stop, it downshifts into 1st hard.
 
1 - 19 of 19 Posts
Top