Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Cummins of the Month Challenge!
1 - 10 of 10 Posts

·
Registered
Joined
·
355 Posts
Discussion Starter · #1 ·
01 2500 2wd
So wife took the truck to town this evening on the way back she felt it cut out a couple times. Then the wait to start light was coming on and going off randomly. She said it then had no power but was still running she pulled over and shut it off. It started back up, off she went to go but still had no power. She went to pull on over and had no power steering or brakes while it was still running and then it quit and would not restart. She then heard the lift pump running. She was only about a mile from the house headed that way and when I got there its pretty much as described. I've got all kinds of lights on the dash except when you turn the key on wait to start does not come on. I also have the no bus on the odometer diode. The lift pump is continuously running I had to pull the positive cable to shut it off. It is not however pushing any fuel up as I cracked #1 and #3 and had her crank and no fuel there. Wait to start light also comes on after switch is shut off and stays on even with the key totally out then it eventually goes off. I brought tools and unplugged the ECM and plugged back in did not change anything. I have a scanner tried to hook up but could not get it to communicate but I didn't mess with it a ton. It was 9:00 and raining. Just got it pulled back home and under the carport. I just had the ECM rebuilt by auto computer specialists back in the spring and it's been great. Just took the truck on about a 250 miles trip last weekend and it was awesome. This has just popped up out of nowhere. I need help and fast because we are now down to 1 vehicle.
 

·
Registered
Joined
·
387 Posts
I know this sounds mean, but welcome to the club. I have had that and or similar experiences. I have added, cleaned, and shined grounds to no avail.
Now my dash lights quit...ok
Then my seat belt system went intermittent -locking / unlocking
and several other weird anomalies.
Mind you I have spent endless hours and money trying to solve this.
As of late a continuous battery drain....ugh
BUT
with the wife out there and better hearing, we have diagnosed a weird sound from a box under the dash-called a
BDC body control module I think it also says CTC on the side of it?
Anyway, I am finding out it is another computer that runs dash lights, interior stuff, cel, chimes etc etc
I am going to talk to a shop in FL that repairs modules tomorrow...about 200 bucks for this one .
I still have no idea what it takes to get this thing extracted out...
Good luck..hope this helps
PS- Once I unhooked the Batts and held the pos and neg terminals together for a few seconds and that cured everything for a month..
 

·
Registered
Joined
·
21,458 Posts
Sounds to me like a major short in the ECM because that would be related to a lot of those electrical issues and running. I do not think a bad VP would act like that electrically in the other systems. If you know somebody with a 01/02 you can try switching ECM's and test it that way. 98-00 will not work.
 

·
Registered
Joined
·
355 Posts
Discussion Starter · #4 ·
Just called auto computer specialists and they seem to think it is something with the ECM between no bus, no coms and the wait to start light being weird and want me to send it in for warranty.
 

·
Registered
Joined
·
21,458 Posts
OK sounds like good idea.
 

·
Registered
Joined
·
355 Posts
Discussion Starter · #6 ·
So when key is flipped the odometer flashes a few times on the no bus comes on. I also get nothing with the key flip trick. cleaned up some grounds, cleaned PCM and ECM connectors. Ended up just pulling it and shipping it off.
 

·
Registered
Joined
·
95 Posts
Same company I sent mine to. They had a fairly quick turnaround and while it was a little pricier than I had anticipated, have not had any issues since.
 

·
Registered
Joined
·
79 Posts
I’m guessing a new/rebuilt ECM will cure your problems
 

·
Registered
Joined
·
21,458 Posts
Use a scan tool not the key.
 
1 - 10 of 10 Posts
Top