Dodge Cummins Diesel Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
So see if anyone can figure this one out im lost. I had to replace my fuel rail pressure sensor...After changing i had the P0628 Code come up everytime i started my truck... i still have my fass in my truck...(not the glacier yet)
that code is for my stock lift pump wich is gone...
my truck quit a block from my house and there it sits. could this be a relay?
i can still hear the fass kick in??
 

·
Premium Member
Joined
·
1,127 Posts
So see if anyone can figure this one out im lost. I had to replace my fuel rail pressure sensor...After changing i had the P0628 Code come up everytime i started my truck... i still have my fass in my truck...(not the glacier yet)
that code is for my stock lift pump wich is gone...
my truck quit a block from my house and there it sits. could this be a relay?
i can still hear the fass kick in??

Whats yer fuel pressure doing from the FASS?
 

·
Registered
Joined
·
78 Posts
Discussion Starter #3
I can only see rail pressure, (no gauges for the fuel)
...when i turn the key on its at 3 to 7 psi for the rail pressure.
 

·
Premium Member
Joined
·
1,127 Posts
I can only see rail pressure, (no gauges for the fuel)
...when i turn the key on its at 3 to 7 psi for the rail pressure.
That is an important reading.....at least lets you know the performance of the low pressure side of the fuel systems. I would suggest checking that out.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #5
Any idea why that code would come on after my fuel rail pressure sensor change?
 

·
Premium Member
Joined
·
1,127 Posts
Any idea why that code would come on after my fuel rail pressure sensor change?
How did you disable the intank pump when you put the FASS in? We used to have customers disable the gnd wire (Pin #1) to the pump and leave the power wire hooked up to referance the ECM so the code would not pop. With our new harness, this is not needed any more and power from the ECM is triggering the Relay in the harness.

If you disabled both wire...this would cause a code to pop.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #7
I had the pump put in by a local shop so im not sure. its been a year since they put it in. But what i did do was bump the starter on my truck. i checked for fuel at the cp3 with the key on, i noticed the fass pump sounded different than normal. So i left the pump running and cracked my filters open and then closed them. I then turned the truck over for 5 seconds...no start... i repeated the process after checking all fuses and connections....the only thing i didnt hook back up was the quadzilla rail pressure gauge.the truck started instantly. and there is no more code..is it possible this gauge could be defective...only 2 days after i installed it ive had to replace the rail pressure sensor and had this fuel problem. > hey Diesel-Dan thanks for your help.
 

·
TECH SPECIALIST
Joined
·
408 Posts
do you have a way of reading the rail pressure with a chip or other device make sure that you are getting 5000psi of pressure in the rail
 

·
Registered
Joined
·
78 Posts
Discussion Starter #9
Yeah i also have an edge insight monitor...it also reads the rail pressure...its through the roof..went and hooked up my 40foot 5th wheel and pulled it home, its working good now.
i think the quadzilla rail pressure gauge is faulty...i cant think of anything else it could be. i havent changed anything else.
 
1 - 10 of 10 Posts
Top