Dodge Cummins Diesel Forum banner

Truck just started surging and popping upon heavy acceleration

602 Views 3 Replies 4 Participants Last post by  easymon
Hey all, I've got an 05, with an Edge intake and exaust, built tranny, thats it. I changed nothing on the truck for about 6 months but this morning every time I laid into it it started surging and popping, even thought I heard a bit of detonation under the hood (this was in level 6) so I tried all of my other power levels and the same happend with less severiy. on the stock setting it seemed to run just fine. Could my lift pump be crapping out? Truck just turned 109K miles. Thx in advance for your thoughts!
__________________
1 - 4 of 4 Posts

· Registered
Joined
·
341 Posts
mine did the same thing with just my power pup and its my cp3 or injector pump w/e you wanna calll it so my truck is down till i can get a new one. is your pump thats in the tank running when you just turn the key to the run position if it is then its probly your cp3 if not then its your lift pump
 

· Registered
Joined
·
306 Posts
Hey all, I've got an 05, with an Edge intake and exaust, built tranny, thats it. I changed nothing on the truck for about 6 months but this morning every time I laid into it it started surging and popping, even thought I heard a bit of detonation under the hood (this was in level 6) so I tried all of my other power levels and the same happend with less severiy. on the stock setting it seemed to run just fine. Could my lift pump be crapping out? Truck just turned 109K miles. Thx in advance for your thoughts!
__________________
Start with the fuel filter, then it could be a bad batch of fuel, rare but it happens. If both of those are ok then you probably are draining the fuel rail so a secondary lift pump may help you.
 

· Premium Member
Joined
·
1,302 Posts
i would 1st take the edge out first and go from there they have been noted to have bad harness or modual. dos it run alright exept turned up and pushing it hard if thats the case i would look at rail running low .start checking presures
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top