Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
346 Posts
Discussion Starter · #1 ·
My truck has no power at all goin down the road and my boost gauge reads zero goin down the road there is no boost what so ever. My egts are around 1100 goin down the road doin nothing. If i put my foot in it in 6th gear there is black smoke like crazy. I dont have the chip in it anymore all i have is the injectors, airbox, and exhaust. If its in 6th and u put your foot in it it will go no where but smoke forever. My airbox is covered in soot. I dont know where the smoke is coming from under the hood but when i start it up with the hood up you can see smoke come out. I think theres somthin wrong with the turbo but im not sure. Anyone have any ideas?
 

·
Registered
Joined
·
470 Posts
Sounds like the turbo is bad, or you have a cracked exhaust manifold. Maybe even a cracked exhaust housing on the turbo. If there is a crack in either of these, you should be able to see the crack, will be heavy with soot.
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #3 ·
Took it a part today and the smoke was from the downpipe on of the bolts that hold it to the turbo were missing so i fixed that and the boost problem was cause the air filter colapsed. So im gona call them monday and they should send me a free air filter i would think since ive done nothing to the old one to make it colapse.
 
1 - 3 of 3 Posts
Top