Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
Hi guys, i have a 2000 4x4 automatic cummins with 257,000 miles. The last few months the engine seems to cut out when im driving it for extended periods of time. In recent history i have replaced the throttle position sensor, added a quadzilla max mpg, and added an aftermarket intake. My rpm gauge will flutter back and forth when im driving at a constant speed. The engine seems to lose power than gain it back instantly. I have changed the fuel filter recently and this still did not help. Also sometimes when i accelerate quickly in town, it seems to really hesitate and cuts out intermittently. It does not do this all the time just occasionaly. I have not put a fuel pressure gauge on it. the truck does alot of running around on the farm, no real hard pulling. thanks for anyone advice
 

·
Registered
Joined
·
1,082 Posts
you definatly need to check that fuel pressure....:thumbsup
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #3 ·
where do you reccomend that i check the pressure at? I have a gauge in the shop, it says not to put on diesels, but the guy that sold it to us said that it would be fine. I have tried to check the pressure but the darn thing lost prime and was hell to start, i hooked the gauge up at the the valve behind the filter.
 

·
Premium Member
Joined
·
3,941 Posts
You can pull the codes by turning the key to on then off 3 times, leave the key on the 3rd time. Have a pencil handy to write the codes down, they will display in the ODO.

Let us know what if any codes you get. Hate to say it, but on the surface, sounds like the electronics are flaking out on the VP44..
 

·
Registered
Joined
·
1,082 Posts
well i know on the Banjo bolt on the actual pump, has a place for a guage. It should be a black cap screwed on the valve, guessin you take it off and screw your guage on there, you shouldnt lose prime that way:w:
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #8 ·
thats right where ive been putting it. the truck will run for about 30 seconds, just enough for me to start it then look at the gauge (which reads zero) then it would die.. I got it started after a few cranks. then drove it around the block and it was fine... it started up right away.. It seems when i hook up the gauge it relieves pressure and causes it to shut off.
 

·
Registered
Joined
·
609 Posts
that really sounds like a lift pump that has given up the ghost...and probably already taken you VP to a certain extent...
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #10 ·
we replaced the lift pump about 25,000 miles ago... my original problem is that the truck seems to cut out at fast acceleration only on occasions, and on occasions when im going down the highway... I can drive it for 2.5 hours then it will act up for the rest of the trip. I dont know why i cant put a gauge on it to check the pressure without it dying on me. It starts fine everyday. I never have problems with it reving up and down in town, its when im on a long trip is when it has the problems. This sounds really crazy but it seems like somthing gets hot and causes somthing to short out. Thanks for all the replys you guys are great!
 
1 - 10 of 10 Posts
Top