Dodge Cummins Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Wondering if I can get some opinions on this. Own a 2018 ram 2500 with the G56. Trucks feeling a little sluggish on power and I’m not sure if that’s how it’s supposed to be or there’s something wrong. 67,000 km on the truck. 35” tires. Completely stock. Clutch isn’t slipping. Did a 0-60 time today which was 14 seconds.

Even when on the highway and trying to pass, I’ll be at 100 kmph, rev match and down shift to 5th. Truck will be revving at 3000 and slowly gain speed.

I was towing the boat and trailer which is only 3,000 lbs combined. In 6th gear, there was absolutely no power to accelerate.

Could this be the VGT? Or is it simply the way she goes having 350 hp and 660 TRQ?
 

·
Registered
Joined
·
14,171 Posts
Is this truck new to you?

Any real issues should post a code.

And, in a manual trans truck, especially one with taller than stock tires, you won't have strong acceleration in 5th or 6th gear.
 

·
Registered
Joined
·
5,705 Posts
35s aren't too terribly big over stock. i run 37s and as soon as that turbo spools she pulls hard. she's happy shifting around 2500 and will stop revving at red line. it's not fast, by any means, but it doesn't seem under powered
 

·
Registered
Joined
·
7,152 Posts
Joined
·
2,646 Posts
What are your boost, EGT, low side and high side fuel pressure readings when accelerating hard?
 

·
Registered
Joined
·
1,941 Posts
Owned my 16 since new, 35s and 37s on stock gears and my truck had plenty of power rowing through gears. Definitely a different animal since the 4.10s and delete but no complaints when stock, and i towed over 12k plenty with no issues or complaints.

Also unless something changed between 16 and 18 you’re not even reaching 3k stock let alone accelerating past it, it’ll defuel around 2800 i think.
 
  • Like
Reactions: N of 60

·
Registered
Joined
·
240 Posts
If it helps my 2017 g56 felt slower then my 01 47re when I first bought it. It’s a lot better now
 

·
Registered
Joined
·
122 Posts
I felt the same way when I got mine. Something just didn't feel right and I knew the 37's didn't slow it down THAT much.

When I replaced my actuator after it threw a code after 2 years of wondering what could be the problem. It was 10 fold better.

It's a guess, but something to think about.
 
1 - 8 of 8 Posts
Top