Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Cummins of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter · #1 · (Edited)
Truck died in the Taco bell drive through. Turned it off so the lady could hear me, no power when I go to turn it back on.

symptoms/History:

-Fuel guage sometimes would read incorrectly occasionally
-ABS light, and e brake light came on last week on the drive to work, were off when I went to luch. E-brake light is impossible as I have disconnected the wires from the ebrake.
-Airdog had to be wired for a on/off switch, as where the relay connects to the factory harness, was not "activating" the switch.

-No fuel pressure guage, but have idiot light, and have never had problems.

-Autometer Pyrometer guage works sometimes. connections are good. switched 12v comed from the headlight switch, ground from the same.

-Edge Comp installed last summer.

-VP44 and airdog 150, both installed last summer new.
-Crank possiting sensor installed 2 winters ago.
- Both batteries are brand new

Thats all I can think of right now. My first thoughts was a bad ground, but I have looked everywhere I can think of. Could the ECM have gone bad?

On a positive note the ladys in the taco bell felt bad that I had to push my truck through the drive through and gave me my order free.

Any help is much apreciated.

Dan
 

·
Mopar1973Man.Com
Joined
·
26,259 Posts
Truck died in the Taco bell drive through. Turned it off so the lady could hear me, no power when I go to turn it back on.

symptoms/History:

-Fuel guage sometimes would reads incorrectly
Need to get this fix soon... :doh:

-Airdog had to be wired for a on/off switch, as where the relay connects to the factory harness, was not "activating" the switch.
Hmmm... This isn't good either did you ever check into this and see why its not operating properly?

-No fuel pressure guage, but have idiot light, and have never had problems.
Becareful here too... The low pressure light normally trigger at 3-5 PSI and minimum pressure the VP44 needs is 10 PSI so you could have more problems...

-Autometer Pyrometer guage works somethimes. connections are good. switched 12v comed from the light switch, ground from the same.

-Edge Comp installed last summer.

-VP44 and airdog 150, both installed last summer new.
-Crank possiting sensor installed 2 winters ago.
- Both batteries are brand new

Thats all I can think of right now. My first thoughts was a bad ground, but I have looked everywhere I can think of. Could the ECM have gone bad?

On a positive note the ladys in the taco bell felt bad that I had to push my truck through the drive through and gave me my order free.

Any help is much apreciated.

Dan
Well for starters I'm going to ask my typically 2 questions...

1. What your fuel pressure like? Regardless of the low pressure light you might find its too low...
Lift Pump Diagnostics

2. Got any Error codes?
OBD II Error Codes

If the ECM bad you'll get a P0606 error code...
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #3 · (Edited)
with all these electrical related issues occuring around the same time, It makes me think it is one thing. I didn"t want to replace my fuel sender and come to find out it is something else.

with the airdog, I couldn't figure out why it wasn't "switching" from the factory harness, I was gonna run it with an on/off switch untill summer break at college. 70 hrs a week between work and college suck up all my free time.

I have a stewart warner fuel pressure guage, ordered the sender today from summit. Gonna install next weekend.

I didn't notice any codes last time I checked with the 3 quick key turns. Truck isn't getting any power so I can't check now. Going to read my FSM and probably pull the ECM and PCM and take them down to the local cummins shop and have them check them.
 

·
Registered
Joined
·
193 Posts
You might want to check the fuses and relays.
 

·
Mopar1973Man.Com
Joined
·
26,259 Posts
I didn't notice any codes last time I checked with the 3 quick key turns. Truck isn't getting any power so I can't check now. Going to read my FSM and probably pull the ECM and PCM and take them down to the local cummins shop and have them check them.
Won't work... You need to drag the entire truck down to the Cummins Shop they can't work with the unit separate from the truck...:doh:

Trust me I had the same problem with my Mom's 96 Dodge and had to trailer it down to a Dodge Dealer to have it checked to find out the PCM was fried and then trailer it back down to have the VIN flash to the new PCM before I could start it...
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #6 ·
all fuses are good, relays too. Guess I'll have to have my buddy trailer me down there.....ughhh a ford pulling a dodge. Thanks for all the help
 

·
Registered
Joined
·
992 Posts
Been here before. First how much fuel is in the tank for certain? When my sending unit went bad I had it read 1/2 tank when the tank was in fact bone dry. If its low and you have a AirDog 150 there is a problem. Add about 10 gals, prime, bleed the air and crank it till it starts letting off the starter every 20-30 seconds and giving it a few minutes to cool.
 
1 - 7 of 7 Posts
Top