Dodge Cummins Diesel Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
913 Posts
Discussion Starter #1
So I have a suncoast full billet trans. Yesterday it wouldn't shift out of 2nd. I checked fluid and it was 2 qt low. I added the fluid and it now wont engage any reverse or drive. I found out if I start the truck and switch immediately to either reverse or drive it will go into gear. It seems it's starting in 2nd and wont switch to 3rd. I have the gm solenoid so I dont know if I should replace that and the transducer or if maybe something else is wrong.
 

·
Registered
Joined
·
913 Posts
Discussion Starter #2
Well guess I'll drop pan and check for shavings.i was thinking about adjusting the front band but since reverse doing the same seems must not be the band's. With it shifting into gear after starting it seems it maybe a pressure issue that's why I'm thinking solenoid and maybe a new filter will help. Input welcome before I dive into it
 

·
Registered
Joined
·
913 Posts
Discussion Starter #4
Come on mater need your advice. "Cerb"
 

·
Registered
Joined
·
913 Posts
Discussion Starter #5
No codes. I used a smarty and a innova scanner. I dont have the top of the line to read everything.
 

·
Registered
Joined
·
913 Posts
Discussion Starter #7
Past due for service. You think fluid filter would cause this?
 

·
Premium Member
Joined
·
15,181 Posts
Unless the trans has imploded, no the filter won't cause that. If you cannot at any time get drive something happened to the direct clutch pack and that will fail reverse also. Drop the pan and see what it looks like. Change the transducer if it doesn't look bad in the pan. Otherwise, sounds like it needs to come out and be torn down.
 

·
Registered
Joined
·
1,635 Posts
You will still have forward if you have a failed direct clutch. You won't have reverse, but you will have forward. Given that you can engage both forward and reverse immediately after startup, I would be looking for a plugged filter at this point.

Your 2nd gear starts are likely a different problem; a transducer problem if I had to guess.
 

·
Registered
Joined
·
913 Posts
Discussion Starter #11
Ok thank you. It's raining now but I might just go drop the pan anyway. Anticipation of spending thousands has me all excited.
 

·
Registered
Joined
·
913 Posts
Discussion Starter #13
That's water droplets n pan. I thought it was metal but it's raining and little got in there before I could get in garage
 

·
Registered
Joined
·
913 Posts
Discussion Starter #15
Yes. Long while. Should I pull and take in to be flushed and fixed or is it something that's doable here in the garage. I'm pretty mechanical just trans I've never dove into
 

·
Registered
Joined
·
1,635 Posts
Just clean the pan out, put a new filter on it, and adjust the bands. Put it back together and fill it with clean fluid. You may want to throw a transducer in it while you have the pan off to see if that was your 2nd gear start issue.

If you really want to be thorough, drive it for a few hundred miles and service it again.
 

·
Registered
Joined
·
913 Posts
Discussion Starter #17
Thanks man. Should I do a GP solenoid or can you clean those?
 

·
Registered
Joined
·
1,635 Posts
If you already have a GM solenoid in there, probably just pull it out and make sure its screens are clean. You could go ahead and just replace it if you've got a few extra bucks. Wouldn't really be a waste of money...
 

·
Registered
Joined
·
913 Posts
Discussion Starter #19
Ordered the gm solenoid and transducer filter and I'll get some fluid.i didn't check specs on bands but I could barely get finger tips in there so they aren't way out of adjustment. Anything else anyone think of while waiting on parts?
 

·
Registered
Joined
·
913 Posts
Discussion Starter #20
I pulled filter today and was looking while under there so it is a dnc block with gm solenoid but I ordered a new set anyway cause my tranny guy was kinda iffy. I notice the transducer is the plastic model in which I ordered the bd kit all from thoroughbred. I know they are pricey but they had what I wanted. I got over 150k on the trans from last rebuild. This is the 4th time I'm having issues with the trans. I thought I had a reliable trans but if this is going cost another 4k I'll probably drop a g56 or 5600 in here, not quite sure. But the almost 10k in it is getting ridiculous.
 
1 - 20 of 28 Posts
Top