Dodge Cummins Diesel Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
189 Posts
Discussion Starter · #1 ·
Since, I bought the truck it has been having this problem where when you start it up and go the first couple hundred feet, if you hit a bumb or take a hard turn, then it feels like it goes into neutral for a couple seconds. first time it did it, i was revving the engine like wtf? and then it violently popped back and took off. now i always wait for it to pop back in before I hit the gas. it seems like once it does it once then it it fine after that. and it usually only happens when the truck hasnt been driven for a couple hours. Any ideas? Im trying to get an idea as to how much its gonna cost. I dont wanna jack up the tranny but i dont got a whole lot of green so it a tuffy.
 

· Premium Member
Joined
·
11,940 Posts
From your description, it may be no more than cnverter drainback.. Try setting in neutral for 30 seconds or so in "neutral" an see if that reduces the issues.
 

· Registered
Joined
·
189 Posts
Discussion Starter · #4 ·
It also seems like it slip when in 4LO even when it it warmed up. Like when i go from no gas to kinda to about half throttle or more.
 

· Registered
Joined
·
189 Posts
Discussion Starter · #5 ·
From your description, it may be no more than cnverter drainback.. Try setting in neutral for 30 seconds or so in "neutral" an see if that reduces the issues.
If there is TC drainback does that mean I need to do anything to it? Or is that just a permanent problem.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top