Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 16 of 16 Posts

·
818
Joined
·
2,246 Posts
Discussion Starter · #1 ·
I've been having an issue lately. My Trans won't shift out of 2nd and into 3rd at full throttle. If i let off it will. It only does it on the 2 to 3 shift. I want to see if anyone has any ideas. The trans only has about 2,000miles on it. I think its a valve sticking in the VB. Anything else that it might be??
 

·
Registered
Joined
·
55 Posts
i had the same problem. Plug up something to your tranny to read the gov. pressure. all i had to do was replace a stupid solenoid that cost $20. Hands down to Dusty Hawk though, i was on the phone with him constantly and we were finally able to work it out.:thumbsup How long have u had your tranny?
 

·
Registered
Joined
·
55 Posts
mine went from a hanging 1st to a very hard 3rd shift, then to 4th. If it was in the 2nd gear range it would kind of kick-out of gear until the RPM's came back down. Hook up a manual gauge to read the gov. pressure. That's how i diagnosed my problem. It wasn't dusty's fault, it was just a bad solenoid from Mopar. Good Luck though. i know the aggravation.
 

·
Shiftin Fool
Joined
·
1,185 Posts
yes there has been quite a few issues with that sensor. has nothing to do with the HTS trans at all. i've seen stock ones have the same issue.
 

·
Diesel Junkie
Joined
·
4,683 Posts
Mine has just started doing the same thing......at WOT , mine will act like it goes in neutral when it shifts from 2nd to 3rd.....rpm's shoot up....as soon as I let out of it,it will shift.
I thought it was the tipple disc to , but the dealer said they have had several of those solenoids go bad.
 

·
818
Joined
·
2,246 Posts
Discussion Starter · #7 ·
Thanks for the help guys. I have nothing bad to say about Dusty and HTS, this trans has been awesome. I am going to hook it to the scanner today and check out what the pressures are doing. Sounds like its just the solenoid though.
 

·
818
Joined
·
2,246 Posts
Discussion Starter · #8 ·
Got a StarScan tool and it looks like the governor pressure solenoid is the culprit. I'm going to be changing that and the overdrive solenoid since i'm there. One question though, will I have to pull the valve body to change them and if so, is there a gasket for the valve body that I will have to change??
 

·
818
Joined
·
2,246 Posts
Discussion Starter · #9 ·
Bump.... Anyone know what I'm up against in changing both solenoids? I don't want to have to drop the pan again. This will end up being the second time and the third time for Amsoil fluid. Had a leaky pan gasket the first time.
 

·
Registered
Joined
·
573 Posts
I changed both the sensor and solenoid on mine, Not tough at all. The only pain would be dropping the fluid if you don't have a hytec pan. With the cover off you'll be able to see both sensors easily. My problem was a little different, kinda like it was shuttle shifting between 2nd/3rd. If I was slowly accelerating it would hesitate, but when given the pedle would shift perfect. Changing both sensors didn't change a thing tho. Might wanna consider adjusting the bands while your in there.
 

·
Registered
Joined
·
1,095 Posts
this might be whats going on with mine, when im running around 30 mph and tramp on it will almost seem like it is neutral then shift in when i let off? is that around where the 2nd to 3rd shift is? how can i find out forsure?
 

·
avatar challenged
Joined
·
4,669 Posts
Hey mine is doing that too. when i hammer it it seems to just rev up real hard for a second then it goes, if i let up a second and get on it again then its ok. Im getting ready to do the tsb for the transducer and gov. pres. solenoid and i hope that solves it
 

·
Registered
Joined
·
1,095 Posts
ok let us know if it fixes the problem
 

·
Registered
Joined
·
37 Posts
Bump.... Anyone know what I'm up against in changing both solenoids? I don't want to have to drop the pan again. This will end up being the second time and the third time for Amsoil fluid. Had a leaky pan gasket the first time.
If you are going to change the overdrive
and converter lockup solenoid you will have to remove the valve body.
The governor pressure solenoid and the pressure transducer are easy to change with out removing the valve body. they are on the passenger side of the transmission.
 

·
Registered
Joined
·
35 Posts
while on the subject of tranny fluid, I just bought a 2002 4x4 with an auto tranny and the seller told me he was putting synthetic tranny fluid in it and was having good luck with it, she has 72,000 on her and no problems yet, I'm going to change all the fluids and was wondering what you guys recommend for the diff's and tranny
 

·
818
Joined
·
2,246 Posts
Discussion Starter · #16 ·
Here's the update, changed the governor pressure solenoid and transducer last night. Pretty simple, except for the loss of fluid, and now it shifts from 2 to 3 but with a major hesitation almost like the feeling of hitting the rev limiter in my camaro. I also found two of the 10-32 torx head screws that hold the VB were in the bottom of the trans pan and a couple others were loose. Talked to Jason at Diesel Nut and he was talking to Dusty and it sounds like a VB issue. Looks like I'll be replacing the VB now. Jason and Dusty have been helpful as the rest of you guys have. I'll keep you posted
 
1 - 16 of 16 Posts
Top