Dodge Cummins Diesel Forum banner

1 - 13 of 13 Posts
K

·
Guest
Joined
·
0 Posts
Discussion Starter #1 (Edited)
alright just started the truck up and check engine light came on i got a 0122 tps low voltage. for a few months ive notice when driving down the highway or interstate at a constant speed the rpms with sometime go up and down about 25rpms and now the code has come up i can hardly even touch the pedal and it will rev to 1000rpms and stay there till i touch the pedal again only does this sometimes. so my guess is the apps is bad. but ive read if its just a low voltage code not both a 121 and 122 to check the batteries and alternator cause they could be bad. i know a new apps is like $400 from cummins but i saw a link for this apps and its only $160. http://mopar.cumminsforum.com/tips/c...eplacement.htm
so what do you guys think $160 is better than $400
 

·
Registered
Joined
·
482 Posts
try the 160 one, i think Genos garage has them as well for 175. I am on my third AAPS from Cummins now. Not a one of them has lasted longer than 4 months. Cummiins keeps replacing them under warranty and I keep putting them on untill someone gets a clue as to why they keep going bad.
 

·
Premium Member
Joined
·
19,886 Posts
alright just started the truck up and check engine light came on i got a 0122 tps low voltage. for a few months ive notice when driving down the highway or interstate at a constant speed the rpms with sometime go up and down about 25rpms and now the code has come up i can hardly even touch the pedal and it will rev to 1000rpms and stay there till i touch the pedal again only does this sometimes. so my guess is the apps is bad. but ive read if its just a low voltage code not both a 121 and 122 to check the batteries and alternator cause they could be bad. i know a new apps is like $400 from cummins but i saw a link for this apps and its only $160. http://mopar.cumminsforum.com/tips/c...eplacement.htm
so what do you guys think $160 is better than $400
well one thing have you tried an APPS reset? another thing contact jmd025 (josh dilmore) about that APPS on mopar man's site. he just bought one the other day :thumbsup:
 
K

·
Guest
Joined
·
0 Posts
Discussion Starter #4
im goin to reset the apps today but i know a few guys that have the timbo apps and was told its a better unit than the oem one so thats the one i will get if i continue to have problems
 
K

·
Guest
Joined
·
0 Posts
Discussion Starter #6
well which one should i use the one where you unhook to battery cables or i was also given one about reseting the voltage
 

·
Mule Barn Proprietor
Joined
·
11,118 Posts
Hey! Yeah, If you get a 121 AND 122 code, the APPS is shot. Resetting wont help. I got the "Timbo" APPS from the link above. It is really easy to replace and set up. Great instructions included. Can't beat the price either.

I had the low voltage code first, and the truck was driving fine, so I started a 200 mile trip. 50 miles later, no throttle! And I had both low and high voltage codes. On a side note, if you get in a bind, set your cruise control at 70, and drive it with the cruise when the pedal goes dead. Thats how I made it home. Idle through the gears till 35, then hit resume!
 

·
Western WA President
Joined
·
8,439 Posts
Hey! Yeah, If you get a 121 AND 122 code, the APPS is shot.
not always....i got that code from having my injection pump return line temporarily disabled as well as the code for injection pump cam malfunction. all from pluggin that fuel return lol. all fixed though and used a scanner to clear all the codes. none have come back.
 
K

·
Guest
Joined
·
0 Posts
Discussion Starter #11
i reset the apps this morning and the check engine light just came on again and it was acting up again looks like im gonna get the timbo apps ordered i dont have dead pedal yet but i dont drive this truck much its my toy so it can sit until i get it fixed
 

·
Mule Barn Proprietor
Joined
·
11,118 Posts
not always....i got that code from having my injection pump return line temporarily disabled as well as the code for injection pump cam malfunction. all from pluggin that fuel return lol. all fixed though and used a scanner to clear all the codes. none have come back.
How does plugging the return line throw a TPS voltage too Low / High code?
 
1 - 13 of 13 Posts
Top