Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

21 - 40 of 57 Posts

·
Registered
Joined
·
1,604 Posts
I think I'm just going to deal with it....I don't need some Dildo trying to keep my truck for two weeks to replace a back ordered part that won't fix it... besides... I'm leaving Florida for Texas next week and don't have time to waste.
 

·
Registered
Joined
·
83 Posts
Any updates on this topic?

I read three or four other threads describing the same issue but no cause of why or solution to fix it.
For me I've had the tow/haul, /eb buttons not work on about 15 different occasions, no amount of shutting the truck off and restarting, opening/ closing doors or letting it sit for a couple minutes does anything to get them working again. They just come back to life whenever they please.

Also my radio/touchscreen has cut out about 4 times now. Screen is blank and all buttons except for power/volume are unresponsive.

One time this winter while I was spun out in one my fields my 4x4 knob wouldn't respond either. Again tried restarting the truck multiple times, (buttons were also dead at the time) Nothing helped. Finally just starting baggin on it and got out with 2wd, I was pretty unimpressed. Don't think the truck enjoyed it too much either...

Dealer doesn't know anything over the phone and the closest one is two hours away. I don't have a backup vehicle and I need mine more than I can give it up for. None of this stuff is debilitating but it's pretty annoying. P.S. fuses are all clean and tight, Can't see anything obvious.
 

·
Buyer of stuff..with OPM
Joined
·
2,607 Posts
Twisted, I have been living with this also although not as bad as you. This sounds nutty but it works to get the switches working again, at least for me. Someone on the TDR discovered this........next time it happens, lock the doors with the armrest switch and then unlock them......my switches work after I do it.:confused013: I made a video of the dead switches to show the dealer at my next oil change.

Sam
 
  • Like
Reactions: 2500/6

·
Registered
Joined
·
83 Posts
That does sound skeptical haha, but hey if it works I'll try it. Thanks! I never thought to make a video to show them, I'll have to remember to try that too.
 

·
Registered
Joined
·
457 Posts
Happened to me a while ago. I actually started a thread about it also. It took shutting the truck off and leaving it alone for about 15 min for the buttons to start working again. Now, if someone could just tell me how to get my TPMS light to go off, I'd be good!
 

·
Registered
Joined
·
1,455 Posts
Mine has done it twice in 3 months. I'm pretty sure it happens from the moment I start the truck but I'm already driving before I notice it. I've tried resetting the 8.4 while driving (holding 2 big buttons) but that hasn't fixed it. In my case I have been able to shut off the truck and restart it immediately without exiting and it worked fine. Last time I did that at an intersection (put it in Park, shut off truck, restart truck, drive).

My 8.4AN has lost all radio presets once but the Sirius-XM presets remained.

A couple of days ago my 8.4 decided to switch to Fahrenheit although my dash display continued using Celsius. I could go into the settings and tick the Metric box and after a few seconds the little check mark would move back to Imperial units. Shutting off the truck and restarting fixed it, even though when I shut it off it ended on Imperial.
 

·
Registered
Joined
·
39 Posts
Funny but not. I was reading this post this morning, just checking into the forum for the week and low and behold my truck did it to me just now. I have no control on that lower cluster of switches, towhaul, seat vents, exhaust brake, etc. And I to am heading off here in a couple of hours towing my toy hauler, with no brake or tow mode. I called the dealership, first time he's ever heard of it?? Amazing, it most be his first day at work. He mentioned for me to check the fuses, yeah right, try looking up what fuse that cluster of buttons is? And if you were to find it, try reading the number it is?? Just what I need on a Friday before taking off for the weekend. I'll let you folks know what happens...
 

·
Registered
Joined
·
1,455 Posts
Odds are, you can just shut it off and it will be normal again after you restart. Still not cool but better than complete failure.
 

·
Registered
Joined
·
79 Posts
Sub'ed. I've run into this probably half a dozen times in 14 months w/ my '13. :banghead: Haven't had it looked at by the dealer as I don't want them fumbling around trying to "fix" something that isn't consistently reproducible.

- Chris
 

·
Registered
Joined
·
257 Posts
Discussion Starter · #31 ·
I've not had this problem anymore, but my truck shows low fuel from time to time even when its full.
 

·
Buyer of stuff..with OPM
Joined
·
2,607 Posts
Well, there might be a solution........here's to hoping......went in for a free oil change and had them look into this for a second time, since the first time ended with a "could not duplicate the problem". This time I brought a cell phone video of the inoperative buttons being pushed and not working. Also, brought up the safety issue of me heading down Cajon Pass( a big one), with a 10,000 lb trailer, AND a set of dead buttons that prevent me from turning on the tow/haul and the exhaust brake.........

So we moved forward and their star system said to replace the switch panel for the fix, and got it done today........so like I said, here's to hoping

Stay tuned......

Sam
 
  • Like
Reactions: Como4076 and 2500/6

·
Registered
Joined
·
640 Posts
Funny but not. I was reading this post this morning, just checking into the forum for the week and low and behold my truck did it to me just now. I have no control on that lower cluster of switches, towhaul, seat vents, exhaust brake, etc. And I to am heading off here in a couple of hours towing my toy hauler, with no brake or tow mode. I called the dealership, first time he's ever heard of it?? Amazing, it most be his first day at work. He mentioned for me to check the fuses, yeah right, try looking up what fuse that cluster of buttons is? And if you were to find it, try reading the number it is?? Just what I need on a Friday before taking off for the weekend. I'll let you folks know what happens...
 

·
Registered
Joined
·
406 Posts
I had this problem on my 13 and I took it in and they did an update and I think in helped a little so it only did it a few times a month...

Now my 14 is doing it...
 

·
Buyer of stuff..with OPM
Joined
·
2,607 Posts
The two things that always worked for me was to shut the truck off, wait a few minutes for the computers to go to sleep, then restart the truck. Also, on my truck, if I locked and unlocked the doors with lock button on the drivers armrest, the switch bank would work again.

Sam
 
  • Like
Reactions: bcflyfisher

·
Registered
Joined
·
262 Posts
I've had this happen 8-10 times in the last year and the garage door buttons have quit a few times also. It doesn't matter what I do they will start working when they want too.
 

·
Buyer of stuff..with OPM
Joined
·
2,607 Posts
The switch panel was the first thing Ram tried replacing on my truck, didn't fix it......FYI, then they tried reprogramming the body control module, no go. Then they replaced the BCM and more reprogramming......no go. Next try was taking half the dash out and replacing two power distribution modules , along with a control module in the drivers door......again, no go:banghead: I realize all trucks are different, this is what I went through over the course of 13-14 months and nine repair attempts.

Supposedly, the Ram engineers worked on a fix for over six months before they told me they can't fix it,:S: learn to live with it..... My gut tells me it is a software issue since they ran out of parts to replace and never fixed it.

Sam
 
21 - 40 of 57 Posts
Top