Dodge Cummins Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
468 Posts
Discussion Starter #1
hey guys, just got back from a 3000 mile run down through utah ans AZ and back to canada pulling a 40 foot 5th wheel.
On the way back I started out first thing in the a.m. and it felt like the tranny was slipping. It wouldnt pull or move except under full throttle and it slowly crawled ahead untill it finally got up to speed. It was starting in first beacuse once it got up to speed it shifted from 1st to 2nd and so on. once I got up to speed everything worked fine but at every stoplight it slipped while pulling away. It did this the entire way home and once I got home it quit acting up and started working properly, except now its making a ticking/ knocking noise.
its most noticable at idle but it does it throuought the rpm range very rapidly at 1100 rpm. it does it wether its in gear or not. It sounds really familliar to a rod knock or bottom end knock but its coming from the t/c flexplate area.
I checked all the bellhousing and torque converter/ flexplate bolts. theyre all tight. Ive got a billet flexplate so im assuming that its not cracked, but anything's possible.
I have codes P0483- Fan Speed
P0868-Governor Pressure sensor volts too high
P2509-Powerdown data lost error
P0251-CP3 Pump regulator control
P0462-Fuel Level sending unit Volts too Low
The tranny is an NADP race, New installed 1 month ago.
Thanks for the help
Dallas
 

·
Registered
Joined
·
468 Posts
Discussion Starter #2
a little more info. i took it to a shop here in town and the tech said it sounded alot like an injector gone bad. Ive never had an injector go so i wouldnt know. When you listen at the top of the engine around the valve cover and intake its quiet, you cant hear anything but under the truck its most pronounced around the bellhousing/ rear of the crank area.
They're gonna have a better look at it tomorrow.
 

·
Registered
Joined
·
91 Posts
Did you get this knock figured out?
 
1 - 4 of 4 Posts
Top