Dodge Cummins Diesel Forum banner

15501 - 15520 of 15523 Posts

·
Registered
Joined
·
8 Posts
Well I was about a "confirm order" click away from the Mag-hytec before watching that video. Salesmen (and data/tests) make the world go round.

If it costs an extra $100 or $200 for fluids that have data showing it's benefits on a $70k+ truck, well then Ill be that guy lol.
 
  • Like
Reactions: RickDeVon

·
Rear Admiral Rickard Onmi
Joined
·
6,257 Posts
Well I was about a "confirm order" click away from the Mag-hytec before watching that video. Salesmen (and data/tests) make the world go round.

If it costs an extra $100 or $200 for fluids that have data showing it's benefits on a $70k+ truck, well then Ill be that guy lol.
Being a salesman myself, 90% of what Banks says and does on those videos is talking out of his rear. There are points where he isn't wrong, but he also cherry picked his "competitors" to show the worst of the bunch, instead of making comparisons to the best of the bunch to "prove" his is really better then what was already offered, at a fraction of the price of his new one
 

·
Registered
Joined
·
1,685 Posts
Changed my CCV filter. Next is transmission fluid and filters.

908808



.
 

·
Registered
Joined
·
1,555 Posts
Being a salesman myself, 90% of what Banks says and does on those videos is talking out of his rear. There are points where he isn't wrong, but he also cherry picked his "competitors" to show the worst of the bunch, instead of making comparisons to the best of the bunch to "prove" his is really better then what was already offered, at a fraction of the price of his new one
Banks is a salesman and slings garbage. Used to be the “name” in diesel. I wouldn’t spend a scent on anything he sells.
 

·
Rear Admiral Rickard Onmi
Joined
·
6,257 Posts
Banks is a salesman and slings garbage. Used to be the “name” in diesel. I wouldn’t spend a scent on anything he sells.
I see you remember the 90s as well
 

·
Registered
Joined
·
8 Posts
To each their own I guess :)
 

·
Registered
Joined
·
152 Posts
I drove my 2017 for the week after dropping off the 2020 for all of the recalls. Man do I miss driving this truck everyday, I even gave it a bath and rotated the tires after getting a little squiggly leaving a customers farm.
 

·
Registered
Joined
·
1,281 Posts

·
Registered
Joined
·
9 Posts
Alpharex headlights? I love mine. How much did you have to adjust them? Mine took a little on the drivers side and a lot on the passenger side. Adjustment is the hole under the hood. T30 long screwdriver.
I went with Amazon AmeriLite version. Not much adjustment needed. My truck is lifted and sits level so I had to adjust them down some. Actually had to drill a new hole in the fender because the adjustment screw didn’t come close to lining up with the stock adjustment hole. And used a 6” Phillips head screwdriver worked great
LED H7 bulbs for lows too. Great cut off line

909147
 

·
Rear Admiral Rickard Onmi
Joined
·
6,257 Posts
I went with Amazon AmeriLite version. Not much adjustment needed. My truck is lifted and sits level so I had to adjust them down some. Actually had to drill a new hole in the fender because the adjustment screw didn’t come close to lining up with the stock adjustment hole. And used a 6” Phillips head screwdriver worked great
LED H7 bulbs for lows too. Great cut off line

View attachment 909147
Invest in Alpha OBD. You need to turn on the code that your truck runs quad headlights now instead of duals. From the factory your low beams will cut off when high beams are turned on due to running the dual housings. While the trucks with factory quads kept the low beams on with high beams. Once you enable that your low beams won't drop off when you turn on your highs.
 

·
Registered
Joined
·
9 Posts
I am looking at the OBDLink MX as we speak actually. It’s funny because since installing I have no high beams at all! It’s Weird
I put the old duals back in just to check that a relay didn’t blow, but high beams still work with them. Put the projector headlights back in again, No high beams. I’m lost. Think it could be an Alfaobd type issue?
 

·
Rear Admiral Rickard Onmi
Joined
·
6,257 Posts
No, that sounds more like bulbs or wiring issues. I would inspect the wiring and connectors on the headlights. If you have a set up to jump wires and bench test the housings, i would do that before getting to excited about anything else.
 

·
Registered
Joined
·
9 Posts
Ok. Yea I switched around everything I could think of to get the high beams working but nope. Point it’s not the new H9 halogen that we’re included. They were preinstalled so idk 🤷🏼‍♂️ May try and take out the H7 LED Low’s and see if that works. Have it’s a current draw issue..
 

·
Rear Admiral Rickard Onmi
Joined
·
6,257 Posts
I would make a jumper set up and test the connections, first at the main connector to the body harness, then into the housings themselves.
 

·
Registered
Joined
·
13,252 Posts
And if you do, please take note of which color wire does what on the headlights.
I'd like to do a bench test of two different sets, but don't want to put the 3500 on the bench to do it.
 

·
Registered
Joined
·
1,685 Posts
Transmission fluid and filter change. A little messy but replaced the pan with a Dorman that has a drain plug for next time around. Got about 10qts out of it.



909160


909161
 

·
Registered
Joined
·
9 Posts
And if you do, please take note of which color wire does what on the headlights.
I'd like to do a bench test of two different sets, but don't want to put the 3500 on the bench to do it.
Will do. I’m curious too. Although it seems the white with blue stripe is the high beam and in the middle location is white with green stripe for ground
 

·
Registered
Joined
·
13,252 Posts
Thanks! Although, if memory serves me, I have no stripes. Solid white and a smaller black, and can't even remember the third color for sure.
Maybe the position of each function in the headlight's connector would be more useful?
 
15501 - 15520 of 15523 Posts
Top