Dodge Cummins Diesel Forum banner

1 - 20 of 33 Posts

·
Registered
Joined
·
136 Posts
Discussion Starter #1
Hi all, I recently noticed some strange symptoms while driving 65-75mph at constant speeds only while under load or going up hill. It will start surging every second and continue doing this until I reach the top of the hill. I watched my boost gauge while it was doing this and it was bouncing between 7-12 psi while it was surging even though I didn't change pedal position at all. I just recently rolled 37k on the clock so my bumper to bumper warranty is gone. Truck is 100% stock and no modifications have been made. Thanks all
 

·
Registered
Joined
·
1,656 Posts
Is this on cruise control? I have noticed mine starting to do the same on cruise control, going up the causeway to the mainland, sometimes it is like I stomped on the gas. Maybe the issue is covered under the engine warranty as it goes to 100K miles.
 

·
Registered
Joined
·
136 Posts
Discussion Starter #4
Completely stock not deleted or tuned. I did not have the cruise control set either. This has been happening since around 5k on the truck just haven't posted about it thinking it was normal. I always run with the EB on full to keep the vanes from gumming up.

Started noticing a month or so ago that when in 6th gear with very light throttle around 55mph i will start giving it some more throttle and the pedal will just be dead almost like the truck lost power until the turbo spools. Feels like dead pedal (which I experience from a stop but not while driving) and the trans will downshift into 5th and hunt for gears until it spools up. I have no CEL either so very odd.
 

·
Registered
Joined
·
2,491 Posts
Turbo is trashed, my 10' did same thing before it got replaced. Do you do a lot of city driving and not use the exhaust brake? Also turbo should be covered 5yr/100k under engine warranty.
 

·
Registered
Joined
·
2,695 Posts
Yeah sounds like the turbo is on its way out
 

·
Registered
Joined
·
1,457 Posts
Mine has surged like this since day one. It is most pronounced from 35-55 mph. If the problem is indicative of a bad turbo, then mine was faulty from the factory.
 

·
Registered
Joined
·
5 Posts
i have a 2016 2500 that is doing the EXACT same thing. I am currently out of town so i brought it to Cowboy Dodge in Cheyenne, WY. They told me it had old software. I told them that i suspected a bigger problem than just software. They flashed the ECM, called me to pick it up and what do you know? It still surges!
 

·
Registered
Joined
·
5,527 Posts
i have a 2016 2500 that is doing the EXACT same thing. I am currently out of town so i brought it to Cowboy Dodge in Cheyenne, WY. They told me it had old software. I told them that i suspected a bigger problem than just software. They flashed the ECM, called me to pick it up and what do you know? It still surges!
This is why dealerships get a bad name. How could they send something out the door that is clearly not fixed?
 

·
Registered
Joined
·
5 Posts
In my opinion, it's because they do not hire mechanics anymore. Most of their "service techs" are oil changers and meter readers. If there are no engine lights or codes, they have no earthly idea how to troubleshoot an issue. I made sure to call the service advisor this morning and inform him that the truck was most certainly NOT fixed and that i was just going to drive it until something came apart and i would make sure that Chrysler knew that their techs could not fix the problem until something broke or an engine light was on. Im covered bumper-to-bumper for 125k anyhow. It just annoys me that the truck is not running correctly and i know there is something wrong with it, i just dont know what it is.
 

·
Registered
Joined
·
136 Posts
Discussion Starter #12
I do a mix of highway and city but my EB is on full all the time. Like you all said the dealer isn't going to do anything about it unless it is throwing codes or is obviously broken. It is hard for me to duplicate the issue but something is not right. Like the previous member said I think mine has done this since new as well. I thought it was just normal........if the turbo is covered under powertrain then I'm good until 100k but just sucks probably won't be able to get it resolved until it breaks.
 

·
Registered
Joined
·
287 Posts
Does it surge with the EB off, too?
 

·
Registered
Joined
·
136 Posts
Discussion Starter #14
I have never driven without the EB so I am not sure if it does it without it.
 

·
Registered
Joined
·
5 Posts
i have been doing some research on this for the last 24 hours, look up the torque converter threads. Their are almost identical scenarios in those threads where the culprit ended up being a bad torque converter... i was on my way to work this morning, when my check engine light came on, so i made a detour to the dealer and dropped it off. i am anxious to hear what they say when they call me back.
 

·
Registered
Joined
·
35 Posts
I have a 17 with 5000 miles, mine does the same thing.

I have a engine light on that was gov pressure to high, I cleared it I am waiting for it to come back then I will take it in.
 

·
Registered
Joined
·
136 Posts
Discussion Starter #18
Thanks all I will just wait and see if it eventually gets worse then take it to the dealer.
 

·
Registered
Joined
·
2,472 Posts
Welcome to crappy Ram tuning from the factory. Live with it or delete it :thumbsup:
 

·
Registered
Joined
·
5 Posts
My 16 does it too. Only when its "lugging" in sixth empty around 1k rpm. no boost change or rpm change just a pulse in the driveline. Gear down to 5th and it stops.
 
1 - 20 of 33 Posts
Top