Dodge Cummins Diesel Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
328 Posts
Discussion Starter · #1 · (Edited)
i have 2 10" visonik subs and a 600watt visonik amp and a 2 months ago my spare tire (87 grand marquis) pressed up against one of my rca plugs and broke it off in the amp. So i took the amp apart and pushed the broken peice out and wired in another rca cable end. and they were working fine until 2 weeks ago they stopped working, so i fiddled with the connections and they worked so i tried to make the connection better, and no work:banghead:. new rca cable, subs still don't work, amp is getting power, and everything is hooked up, but I can't find the problem. any idea's? Thanks
 

·
Registered
Joined
·
328 Posts
Discussion Starter · #2 ·
bump... could an amp show its getting power but its bad?
 

·
Registered
Joined
·
1,186 Posts
Amp can power up but have problems in the signal path. needs to be junked or sent off to be repaired. Being that it is visonik its probably garbage. Let me know if you need help picking out a new amp
 

·
Registered
Joined
·
1,221 Posts
ill help too. if your throwing it away, ill pay shipping.
 

·
Registered
Joined
·
328 Posts
Discussion Starter · #5 ·
what are some good amps that wont hurt my wallet?
Thanks
 

·
Registered
Joined
·
1,926 Posts
I bought this one and like it, its a lil steep on price, but looks real nice and sounds even nicer depending on subs. I have 2 12" kickers

TRX1500D
 

·
Registered
Joined
·
328 Posts
Discussion Starter · #8 ·
probably around the same as the visonik, 600 watts to power the 2 10" subs
 

·
Registered
Joined
·
421 Posts
The amp just needs to be junked, pal. :thumbsup: Go out and getcha new one.
 

·
Registered
Joined
·
328 Posts
Discussion Starter · #11 ·

·
Registered
Joined
·
1,186 Posts
do they have dual voice coils or single? do you have a model number on the subs?
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top