Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 20 of 23 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
broke down---out of town

2000/3500 quit running last night on the interstate.

At first the fass pump wouldn't run and filters were dry---no pressure on gage.

I think the turbo temp monitor may have gone bad. The panel lights would not go off---even with the key out?

I disconnected the TTM and got the fass running, loosened the filters and got them full, then loosened the fitting at the pump and got fuel there.

I can't get any fuel at the injectors.
 

·
SuperDuperMod
Joined
·
2,816 Posts
any cel's? hope your ip didn't take a dump.
 

·
Registered
Joined
·
246 Posts
eskimojoe170,

Fill out your sig so we know what it is your driving. The more information you provide the better.

Where are you broke down at? Someone in here might know of a close mechanic.

Good Luck
 

·
Registered
Joined
·
12 Posts
Truck died last night while driving highway speeds, as if it ran out of fuel. At first, there were all kinds of weird electrical problems. Fass fuel pump is working. Last night, with the key removed from the switch, the fog lights were on and lights on the dash where flickering. Other electrical things (guages and other a few other things) were not working at all. It was not giving any codes when turning the swith on off on off on. Towed it to dealer this morning. They say it is giving the code for bad injector pump and they want $3000 for the repair. Could an electrical problem cause the injector pump code, or could the injector pump cause weird electrical stuff? PLEASE HELP!
 

·
Registered
Joined
·
12 Posts
oh just realized I left out what the truck is. It's a 2000 24 valve 1 ton.
 

·
Registered
Joined
·
12 Posts
the truck is a 2000 3500 24valve cummins. i just posted a new thread, not realizing my dad had already posted this one. The only code it's giving with the on off on off on thing is the generic problem code, I forget the numbers. Towed it to a dealer this morning. They say it's the injector pump, which kind of makes since, but doesn't explain the electrical stuff and the fass pump not working at first.
 

·
Registered
Joined
·
12 Posts
oh, and they want $3000 to replace the injector pump. They now say that it is giving an injector pump code on their reader. Could an electrical problem cause the injector pump to throw a code?
 

·
Banned
Joined
·
2,613 Posts
where you using anything at the time that it happend that was remote controlled? like a toy or something? im being seriouse my wife had a toy going in the truck well it was remote controlled and it sent my dash into seriouse haywire mode now I have to keep the dash lights off on the lowest setting, because when I go to brighten the dashlights it turns all the cab lights on...
 

·
Registered
Joined
·
43 Posts
There is a fusible link in the PDC under the hood that links the alternator to the battery. Mine blew that fuse out and it didn't give any codes. I also lost a IP, when that happens everything should work fine but it just won't run. It will turn over all day long and all the electrical works, it just won't start.

Oh, and put your truck info in your signiture it helps with diagnosis a lot. Hope this helps. Good Luck.
 

·
Banned
Joined
·
2,613 Posts
non dealler I had both injector and pickup pump changed for right about $2000
oh, and they want $3000 to replace the injector pump. They now say that it is giving an injector pump code on their reader. Could an electrical problem cause the injector pump to throw a code?
 

·
Registered
Joined
·
12 Posts
nope, no remote controlled "toys". At least I don't think so. I'll ask my mom. Haha. This is gonna be a funny conversation.
 

·
Registered
Joined
·
12 Posts
nope, just talked to them. Nothing remote controlled.
 

·
SuperDuperMod
Joined
·
2,816 Posts
topher, merged your threads so you could track responses easier
 

·
Registered
Joined
·
12 Posts
thanks rbm. He's going to check that fuse in the pdc right now. Thanks!
 

·
Registered
Joined
·
12 Posts
he checked that cable. He said there is a terminal, but no fuse. He is reading 12 volts on both sides of the terminal.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #16 ·
Thanks for all your help. I tried everything suggested and then some. Just don't know? I'm leaving it at the dealership (10 miles from from where it quit). Just to far to tow it home. I'll post the results when I get it back.

The only thing I know for sure is that "Town and Country towing" (Ball Ground Ga) charged me $200 for a ten mile tow to the motel last night. Sure couldn't sleep after that.
 

·
Registered
Joined
·
246 Posts
Bad injector code....mmmm....you said the fuel filters were dry. Couldn't that have killed your injector pump? If so why did the filters go dry in the first place, I would be more concerned with that.
 

·
Registered
Joined
·
12 Posts
thats why I was thinking that there was an electrical problem, which caused the fass pump to fail, which caused the injector pump failure.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #20 · (Edited)
I'm 35 mi south of atlanta. Left the truck in jasper, ga. Not too far from there to murphy nc.

I've figured out the dash lights staying on. Duh? When the engine quit the turbo was "hot" sooooo the turbo temp monitor kept the switch on (even with the key out) untill the turbo cooled down.

What I can't explain is the fuel filters empty and not being able to get the fass pump running at first???? I'm not sure where to start, but I'm not driving it (with the new ip) and risking another pump untill I figure something out. At least an audible "low pressure alarm. Any suggestions are greatly appreciated.
 
1 - 20 of 23 Posts
Top