Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your truck HERE to be a part of December's Cummins of the Month Challenge!
1 - 16 of 16 Posts

·
Registered
Joined
·
307 Posts
Discussion Starter · #1 ·
Ok like it says. At the park with gf and puppy. Going to leave and truck starts fine. I back up bump the throttle and it starts reving up to 2500 and levels off there. Shut it off. Restart it and imediatly goes up to 2500 and stays reving there. I checked all throttle linkages and every thing is good. Springs in tact and doesn't catch on anything. Any ideas? So I'm currently at the park lol kinda stranded.
 

·
Registered
Joined
·
206 Posts
Make sure that the linkage is returning all the way if it is then it sounds like something in the gov came apart.
 

·
Registered
Joined
·
307 Posts
Discussion Starter · #3 ·
Its returning all the way. And also ill add that I bumped the throttle with it revving and it went up and came back to 2500 and staying there
 

·
Registered
Joined
·
307 Posts
Discussion Starter · #5 ·
Yeah it checks out. All linkages are great. Spring back to the normal positions and everything. Im just glad its a nice day at the park. lol
 

·
Registered
Joined
·
307 Posts
Discussion Starter · #6 ·
And I just ruled out it running off a blown turbo oil seal. I do have some oil in the intake but I pulled the horn off and let it run. And no change at all.. So if it is in the governor where would I start to check. And btw I'm 3 hours from home... And kinda got to get home
 

·
Registered
Joined
·
396 Posts
id pop off the cover and look at your springs. lol i mean you could just launch from every stop light
 

·
Registered
Joined
·
307 Posts
Discussion Starter · #8 ·
i mean you could just launch from every stop light
Already did that lol Im not at the park anymore. I made the 5 mile drive back to the gf's house but yeah stoplights were interesting... :dragster:
 

·
Registered
Joined
·
396 Posts
long distance relationship not only burns up a wallet but in your case its smokin a clutch lol.
 

·
Registered
Joined
·
307 Posts
Discussion Starter · #10 ·
long distance relationship not only burns up a wallet but in your case its smokin a clutch lol.
Sad part is.. this time last year it was a 5th gear nut issue about 10 miles out of town on my way down. I love fixing $hit on gravel parking lots. At this rate i'd be better off with a 6.0 :spank:
 

·
Registered
Joined
·
396 Posts
get her on the hwy. with the 4:10's you should be close to that doin 70mph any ways.
 

·
Registered
Joined
·
289 Posts
did you try turning down the idle screw? it probably won't fix it but it might drop down the revs a little.
 

·
Registered
Joined
·
32 Posts
3 hours farther than you were in your hometown lol. Try taking the AFC and plate out and looking at the rack, make sure it goes in and out about I think 1/2" is all it goes. Make sure to push the shutoff solenoid up or it won't budge.

As in this thing. The green box is what you should watch, don't worry about the thing in red as it just goes up against a spring, the thing in green (the rack) is what should move back and forth 1/2" as you go from idle to WOT (truck won't be running to do this).

 

·
Registered
Joined
·
307 Posts
Discussion Starter · #16 · (Edited)
ok heres the good news.. I get to go home in the morning. lol

The rack was moving as far as it needed to be for as far as i could tell. I went ahead and gutted the afc (yes i know its guna smoke and run like crap) then i adjusted the idle screw down 3 or 4 turns. It now idles about 1000. which is where is was before. So i thought great i fixed it..

Well went inside and got the gf and the pup for a test drive. Started truck again and it took a while to idle back down from a bump of the throttle but it did. I had an extra little spring behind my seat so i put it on throttle linkage. Now it idles down fast. And the pedal is HARD to push with extra spring so im ruling out the option of the throttle not returning all the way.

Idk what the heck is up. I checked the linkage 15 times literally. But i think there is still a problem somewhere bc it idles at 1000 (yes it is where it was before) but i had to turn the idle down which means something else changed somewhere..

So im still a little clueless. governor assembly somewhere? is there a common problem in there that i havent read about yet?

O and ill vouch for the fact that gutting the afc makes smoke lol. I hope no one is traveling east on I-44 tomorrow
 
1 - 16 of 16 Posts
Top