Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Texas
Joined
·
106 Posts
Discussion Starter #1
So the truck I have is in my sig and I have done nothing else to it. I had the water pump replaced when it blew up on me awhile back. The dealer did not replace the thermo so I took it back and they put one in for free. Well it still ran at about 210 all the time and the trans got up to 200. Then one day I was going way to fast and the temp shot to 245 and once I let off the gas and slowed down it cooled to 210 right away. So I bought a new thermo and installed it and it runs at 210 when doing 70 but once you stop at a stop light or park it drops to 170.

I have tried the loosen the radiator cap and warm it up and tighten it and still no luck. What could cause that. It has to be something that happened recently. The truck has 112000 miles on it.

Could it be high EGTs? I have a gauge I just haven't drilled the hole in the exhaust yet.

Any more Ideas would be great.
 

·
Substation Operator
Joined
·
1,152 Posts
is that a dodge thermostat or a cummins one.

The one's from dodge are crap.
 

·
Texas
Joined
·
106 Posts
Discussion Starter #3

·
Texas
Joined
·
106 Posts
Discussion Starter #4
Any ideas?
 

·
Registered
Joined
·
86 Posts
Wrong coolant, wrong mix of coolant (50/50) Adding pre mix to a block not completely drained would be more like (25/75 h20). Did they flush the block with tap or distilled water? For just a few Ideas
 

·
Texas
Joined
·
106 Posts
Discussion Starter #6
Im not sure. I was kind of thinking that but I didn't want to flush the coolant to do that. I will get that done and see if that helps.
 
1 - 6 of 6 Posts
Top