Dodge Cummins Diesel Forum banner

21 - 31 of 31 Posts

·
Premium Member
Joined
·
20,059 Posts
Yeah I removed the quick connects at the engine bay and it looks like I can slip rubber on to them and just use a hose clamp to keep it from leaking temporary. Now, to drop the tank or lift the bed is my next challenge haha

Sent from my LM-G710 using Tapatalk
That's what I did on mine and was still holding for 6 years when the truck died of cancer.

I found that if you removed the drivers side bed bolts and just loosened the passenger side bolts and the fill tube from the bedside you can lift the bed high enough to get to the top of the tank.

If you have 2 floor jacks it's easy to drop the tank also, hardest part would be getting in there to disconnect the fuel lines.
 

·
Registered
Joined
·
310 Posts
Discussion Starter #22
That's what I did on mine and was still holding for 6 years when the truck died of cancer.



I found that if you removed the drivers side bed bolts and just loosened the passenger side bolts and the fill tube from the bedside you can lift the bed high enough to get to the top of the tank.



If you have 2 floor jacks it's easy to drop the tank also, hardest part would be getting in there to disconnect the fuel lines.
I'm lucky enough to be able to use a lift so I think that lifting the bed may be a bit easier. Headed to an auto parts store to get some 3/8" and 5/16" J30R7 line and clamps right now.

Fittings at the engine appeared to be metal, assuming they're plastic at the tank after looking at photos so I'll have to be gentle with the clamps.

Sent from my LM-G710 using Tapatalk
 

·
Premium Member
Joined
·
20,059 Posts
Yes be extremely careful removing the fuel lines at the module, from what i've heard over the years the module is no longer available,
 

·
Registered
Joined
·
310 Posts
Discussion Starter #24
Update: Still in the process of dropping the tank, was going to tilt the bed but with the B&W rollover hitch it's not as easy as it should be. I'm currently siphoning out fuel but was surprised at how good the fuel looks. It's super clear and doesn't have an off smell at all. For >7 yr old fuel that's amazing to me. I now know the sender is also out of wack because it was showing below empty and I've siphoned out 8 gallons already.

PS: don't mind the dirt in the bucket, that was in the bucket when I started. And sorry for the bad photo
 

Attachments

·
Registered
Joined
·
310 Posts
Discussion Starter #25
Update: sending unit is shot, ohm readings are all over the place, nowhere near the 0-90 ohm range. Since I have the tank out I see no better time to replace it. Ran new lines just waiting for the sending unit then I can toss the tank back in and hopefully have an accurate (as can be expected) fuel gauge again!

In the meantime I've been running the truck off a can of diesel. Truck runs great, idle is smooth and no obvious leaks I can see anywhere. Thanks you guys for the help and guidance on getting the truck running. Honestly I expected more difficult time (knock on wood).
 

·
Registered
Joined
·
310 Posts
Discussion Starter #26
Update: after disassembling the sending unit it looked like the small striped contacts were ok, however the small pads that swing with the float and the base had corrosion. After a few attempts of sanding and bending they are consistently going through the ohm range, although about the last 1/3 is activated the "low fuel" light. So going to assume low means about 10 gallons left lol.

After that I tossed sending unit back in and did a custom routing with 3/8 and 5/16 J30R7 fuel/vapor hose up to the engine compartment. Hooked both in and pumped the mechanical fuel pump until there was no air in the line. Bumped the starter and the truck fired right up. Few air bubbles resulted in an occasional stumble but after about 3 minutes of idling it idles smoothly again with no hiccups. During that time I was looking around and to my excitement don't spot any other leaks at the moment!

I'm excited to get working on the truck. Hoping to daily it to and from work in the near future. Thank you guys for all the advice and assistance along the way. Changed oil, fuel filter, added marine 2 stroke oil to the tank, and buttoned everything up and she's starting and running like a champ. Now to address the transmission...

Sent from my LM-G710 using Tapatalk
 

·
Registered
Joined
·
310 Posts
Discussion Starter #27
Well started working ok her and trans is beyond toast, pics below. Hoping I can remove the sludge and rebuild it but I'm certain this gunk is bad news for that valve body.


Sent from my LM-G710 using Tapatalk
 

·
Registered
Joined
·
2,198 Posts
I'd be filtering & reusing that red dyed diesel if I were you, as long as you don't have random tank tests where you're at.
 

·
Registered
Joined
·
310 Posts
Discussion Starter #29
I'd be filtering & reusing that red dyed diesel if I were you, as long as you don't have random tank tests where you're at.
None, have the tank about half full right now of it. Will out the rest in once I get her moving again.

Sent from my LM-G710 using Tapatalk
 

·
Registered
Joined
·
310 Posts
Discussion Starter #31
Watching...hopefully it gets moving soon for you!
Found a great deal on a Getrag 360 with everything I needed. Put it all in with a new 4" custom rear driveshaft and she's driving again! Now it's time to get everything else fixed up! Thanks for all the input!

Sent from my LM-G710 using Tapatalk
 
21 - 31 of 31 Posts
Top