Dodge Cummins Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
So I picked up a 2007 5.9 back in November. The trick had roughly 252000 on it when I got it and I’ve put around 8ish thousand on it. At around 253000 I was driving at around 50mph and a squealing noise started coming from under the hood around the turbo area. It wasn’t too bad but a definite difference in sound. I ended up taking all of my fittings off and checked my turbo bearing and all was good there. I replaced a intercooler hose and checked all other fittings and nothing really stood out to me to be a problem. Put it all back and noise was still there. About 2000 miles later I installed a banks monster ram air-box (not oiled). The truck stopped making the noise until I was driving to work and it was around 80degrees outside and it started making the noise again. Now it’s to the point where it’s no matter how cold or hot the truck is it makes it. 1-3 gear don’t usually make it. When I hit around 2100rpm in 4th it does it. I don’t have gauges or monitor to see if I’m loosing boost. I don’t feel power loss but it’s definitely an annoying sound. It’s like a high pitched squeal. I can’t find anyone anywhere to give me answer but I’ll try and get a video up
 

·
Premium Member
Joined
·
6,693 Posts
Silencer ring in place?
If it went away when you installed intake, then came back I would make sure none of intake plumbing loosened up.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Silencer ring is removed but done before new intake. So am not sure why I keep getting it back. I’ll double check and make sure all is in place
 
1 - 5 of 5 Posts
Top