Dodge Cummins Diesel Forum banner
1 - 10 of 10 Posts

·
Premium Member
Joined
·
797 Posts
Discussion Starter · #1 ·
Can somebody help describe the wiring for the speedometer? I have a 92 W250 and my speedo stopped working which in turn caused my overdrive to stop also.

Where does the speedo connect to, transfer/tranny or rear diff?

After that what do I need to do inn order to diagnose the problem?

Thanks.
 

·
Registered
Joined
·
7,185 Posts
First off replace the first relay on the fender it's the ASD relay .Then make sure the speed sensor on trans is good . It could be alot of different thing's .Could Also be your TPS .
 

·
Registered
Joined
·
4,467 Posts
Check the VSS at the transfer case, drivers side, 2 wires, you'll see it
 

·
Premium Member
Joined
·
797 Posts
Discussion Starter · #4 ·
First off replace the first relay on the fender it's the ASD relay .Then make sure the speed sensor on trans is good . It could be alot of different thing's .Could Also be your TPS .

Any chance you can share a picture to help identify. I've seen a few relays on the fender and to make matters worse this is a totally new topic for me. Thanks.
 

·
Premium Member
Joined
·
797 Posts
Discussion Starter · #5 ·
So the rear differential is out of the question? It all comes down the transfer or relay on the fender?
 

·
Registered
Joined
·
7,185 Posts
Do this Swap the relay's around and see if that help's . then have the VSS tested and go from there . send me a E mail I can shoot you some Pic's tomorrow .
[email protected]
 
  • Like
Reactions: @firstgen4x4

·
Registered
Joined
·
255 Posts
I need help to locate on a 2wd

I have a 92 2wd. Where do I find the speed sensor since I don't have a transfer case? Is it the one on the rear diff or is there one on the tranny? I think the one on the rear diff is my abs sensor, right?

Pics are helpful.
 

·
Registered
Joined
·
4,467 Posts
it will be in the trans, not the rear diff.
 

·
Registered
Joined
·
255 Posts
I found it it was on there but it wasn't screwed on very tight. Would that keep it for me working. it was on hand tight
 

·
Registered
Joined
·
4,467 Posts
I found it it was on there but it wasn't screwed on very tight. Would that keep it for me working. it was on hand tight
that will definitely keep it from working proper. you want it clean, dry, and tightened down to work right. good luck!
 
1 - 10 of 10 Posts
Top