Dodge Cummins Diesel Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter #1
At about 40kmh- 25-30mph i get a distinctive clack of a fubar ujoint. But none of the joints have play what so ever. The sound is consistent under power or coasting. DRW 2015 Megacab. Anyone hear/seen or fixed something similar to this yet? The noise is definitely external of the diffs and speed dependant. Maybe grenade’d park brake idk. Does the rear end need fricmod adjustments maybe? It seems to get more auditable when turn slightly right. Checked the wheel nuts and they are all good. Got the truck last month at 120,000km / 75,000mi been doing it since i got it. No indication of failing parts whatsoever. Thinking about pulling the rear wheels off to look at the park brakes next. But maybe this is a documented issue. Cant find anything on the forums yet though...
 

·
Registered
Joined
·
552 Posts
2 piece driveshaft?
 

·
Registered
Joined
·
111 Posts
When my u-joint started to die on the ‘16 I could only get movement out of it when the rear driveshaft was in 1 certain position... all the needles in one roller of the rear u-joint were gone.

It’s only the 4 bolts that hold the driveshaft to the rear diff, remove them and pull the shaft out. It will slide off the splines in the transfer case easily.
 

·
Registered
Joined
·
5 Posts
Very difficult problem to chase, don’t throw many at chasing suspect parts. If you love you truck like I do then go ahead and buy yourself a set of chassis ears cause your going to have plenty of issues such as this with all the big moving parts these trucks consist of.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #8
Since i started this thread i just kept trucking with the tunes cranked up. Another 3800km or so with regular inspections, Now its getting really noisy. Still no excessive play in any of the joints. Wheel bearings have minimal “slop” so I ordered up 2 new hubs and a lower balljoint that as-well has the tiniest bit play. So strange..Thing sounds like somethings going to pile up. When i hit washboard it chatters. So one might say brake chatter. But everything is tight in the brake department as far as I can tell with a bar and hand wiggle. Gonna see when i get the tires off mid next week. local parts stores/Dealer want $500-600 for a HUB. I ordered one SKF BR930553 for 240 and I thought would give MEVOTECH - H515148 a try for 135 all in.
 

·
Registered
Joined
·
112 Posts
At about 40kmh- 25-30mph i get a distinctive clack of a fubar ujoint. But none of the joints have play what so ever. The sound is consistent under power or coasting. DRW 2015 Megacab. Anyone hear/seen or fixed something similar to this yet? The noise is definitely external of the diffs and speed dependant. Maybe grenade’d park brake idk. Does the rear end need fricmod adjustments maybe? It seems to get more auditable when turn slightly right. Checked the wheel nuts and they are all good. Got the truck last month at 120,000km / 75,000mi been doing it since i got it. No indication of failing parts whatsoever. Thinking about pulling the rear wheels off to look at the park brakes next. But maybe this is a documented issue. Cant find anything on the forums yet though...
You need to remove the driveshaft and check both joints. You WILL find one that is very tight and is seized. That is why it has no play.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #10
All right. Ill get a couple rear shaft joints aswell.. if i’m pulling the shaft out ill just change them to serviceable’s for s and giggles. Thanks
 

·
Registered
Joined
·
52 Posts
Discussion Starter #11
At about 40kmh- 25-30mph i get a distinctive clack of a fubar ujoint. But none of the joints have play what so ever. The sound is consistent under power or coasting. DRW 2015 Megacab. Anyone hear/seen or fixed something similar to this yet? The noise is definitely external of the diffs and speed dependant. Maybe grenade’d park brake idk. Does the rear end need fricmod adjustments maybe? It seems to get more auditable when turn slightly right. Checked the wheel nuts and they are all good. Got the truck last month at 120,000km / 75,000mi been doing it since i got it. No indication of failing parts whatsoever. Thinking about pulling the rear wheels off to look at the park brakes next. But maybe this is a documented issue. Cant find anything on the forums yet though...
You need to remove the driveshaft and check both joints. You WILL find one that is very tight and is seized. That is why it has no play.
No good on the Ujoints. Wheel bearings did not make the plane so that is still open ended. I ended up with Moog 358’s for the rear shaft. I had to take .005ish off each ear on the aluminum side to clear the little plastic grease spreader, no big deal. Sound is still their and heathy. Developed a front axle seal and rear wheel leak though, Looks like i will be getting aquatinted with the r&p’s real soon lol
 

·
Registered
Joined
·
52 Posts
Discussion Starter #12
I finally got time to actually diagnose this hooptie,
something rattling around inside the left rear wheel end. Its unbelievable how the sound can resonate bouncing off the ground and truck. I got new seals and brakes coming on the plane today. Also some calliper slide pins. I managed to brake one off in the bracket when i was trying to free it up... successful extraction though... linked a video of the culprit noise..
https://youtu.be/Rn37IKQtQqw

Thanks for all the input fellas
 

Attachments

·
Registered
Joined
·
52 Posts
Discussion Starter #13
I don’t know what kind of inspection is required to sell used vehicles in Alberta canada but holy hell, I purchased this truck from a huge used car dealer thing called GO Auto.. The last thing i would have thought is the entire braking system in the rear end was Totally messed up one pic is whats was left of both parking brakes (the heinous noise) . Their was only one rattle clip between both callipers and the RH slide pins were completely seized. Just WOW.
 

Attachments

1 - 14 of 14 Posts
Top