Dodge Cummins Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
ok my speedo dont work or odometer so i was lookin under the hood andon the driver side of the truck theres 2 big plugins that plug into connectors setting on top of looks like brake lines well the big one was unplugged but when i plugged it back up my speedo and everything started working but when i made it home i turned the truck off and heard a humming noise under hood i looked it was coming from what i pluggd the connector into so i unplugged the big connector again and it stopped what do i do to fix this issue...thanks?
 

·
Mr. Vehicle Destroyer
Joined
·
11,934 Posts
you need a new electronic control module for the ABS valve itself. There is a motor FET that is latched on (similar to a relay) and it won't let the motor turn off. Leave it unplugged until you get a new controller for it or else it could burn out the motor of the ABS valve.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
ive looked all over the internet for one called advanced they said it was dealer item only how much does one of these modules cost and is there anywheres else i can get it besides the dealer?
 

·
Mr. Vehicle Destroyer
Joined
·
11,934 Posts
I've had good luck with module master ~$130 (not knowing the year of your truck since your signature line isn't filled in it's tough to tell) ModuleMaster | Kelsey Hayes Dodge
 

·
Registered
Joined
·
306 Posts
I just ordered one from the dealer for $390 bucks havent picked it up yet though. . .my truck is a 2001 2500 should i look else where besides the stealership? And also would it be unplugged effect the way the truck runs? like maybe bad fuel mileage and what not?
 

·
Diesel Filled Veins!
Joined
·
5,401 Posts
I just ordered one from the dealer for $390 bucks havent picked it up yet though. . .my truck is a 2001 2500 should i look else where besides the stealership? And also would it be unplugged effect the way the truck runs? like maybe bad fuel mileage and what not?
Only affects ABS as far as I know. You really only need to disconnect one of the plugs to deactivate the motor. When mine was unplugged, the speedo and odometer still worked just fine but like I said, only one plug needs to be disconnected.
 

·
Registered
Joined
·
306 Posts
I must have the one unplugged for the speedo then. . .darn thing hasnt worked in the last month
 
1 - 7 of 7 Posts
Top