Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Cummins of the Month Challenge!
21 - 39 of 39 Posts

·
Registered
Joined
·
4,806 Posts
IDK Id be tempted to talk to a lawyer TBH, the state should not make you get a re-flash just to pass when nothing changed on the truck since the last time.

Or like I said before go to a different shop. This seems more like a smog tech knowledge thing than anything
 
Joined
·
3,500 Posts
CumminsShake, perhaps post on the California section of the forum asking to borrow a Smarty or a nearby Ram dealer that is recommended or what they are doing to pass smog in their Cummins trucks.

If we lived a little closer, we would have flashed your truck with my Smarty S06 already! :)


So I got curious and went out to the garage and connected 2 of my OBDII scanners to my 2004.5 truck.
I'm running an S06 Smarty with the latest 2012 Mads update. The S06 doesn't show I/M status.
I have never checked I/M status on my truck before. Never needed to, never thought about it!

My pretty decent Autel scanner shows all my I/M parameters as "N/A".
My cheapo OBDII scanner also shows all the I/M parameters at "N/A".
 
  • Like
Reactions: Cummins Shake

·
Registered
Joined
·
11,216 Posts
5.7 Hemi,

The reference I found says that diesel 1998-2006 model year vehicles are required to have all monitors complete or ready.

I've searched for others do you have a link or anything by chance. Thanks for all the help guys. I appreciate it.
I sent you a PM for a reliable,competent smog guy.
 

·
Registered
Joined
·
1 Posts
Cummins Shake, I'm a little late to the party but here is my input just in case you are still having issues.
I had a similar problem with my 2006 49 state truck. I don't remember what codes were causing the issue but the smog tech said I had to go to the dealer because the ECM showed not ready to test.
Your profile says your in SanDiego so you'll probably know the dealers in the area. I started in Poway and that dealer said they could not re-flash my ECM to resolve the issue because they didn't have the right machine. A few other dealers said the same thing. I eventually ended up at Rancho Dodge in Kearny Mesa and they were able to flash my ECM which fixed the issue.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #26 ·
Cummins Shake, I'm a little late to the party but here is my input just in case you are still having issues.
I had a similar problem with my 2006 49 state truck. I don't remember what codes were causing the issue but the smog tech said I had to go to the dealer because the ECM showed not ready to test.
Your profile says your in SanDiego so you'll probably know the dealers in the area. I started in Poway and that dealer said they could not re-flash my ECM to resolve the issue because they didn't have the right machine. A few other dealers said the same thing. I eventually ended up at Rancho Dodge in Kearny Mesa and they were able to flash my ECM which fixed the issue.
Went there today! They won't do it. I explained everything, showed the TSBs. They refused. Said it is only for Cali trucks. I explained my truck is a California truck since I brought it into the state.

I scheduled with a referee, I'm over this crap.
 

·
Registered
Joined
·
11,216 Posts
Went there today! They won't do it. I explained everything, showed the TSBs. They refused. Said it is only for Cali trucks. I explained my truck is a California truck since I brought it into the state.

I scheduled with a referee, I'm over this crap.
Great. You'll finally get some relief. I'm still chasing down a P2509 intermittent power interruption issue. It falls on it's face momentarily and recovers only to happen again with no rhyme or reason. Batteries are good,charging system fine,all grounds checked and cleaned if necessary. EFI is set back to stock and disconnected from the OBD11 port. I dread bringing it in but Rancho it might be for a reflash. TIPM power wire is clean.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #28 ·
Great. You'll finally get some relief. I'm still chasing down a P2509 intermittent power interruption issue. It falls on it's face momentarily and recivers only to happen again with no rhyme or reason. Batteries are good,charging system fine,all grounds checked and cleaned if necessary. EFI is set back to stock and disconnected from the OBD11 port. I dread bringing it in but Rancho it might be for a reflash. TIPM power wire is clean.
Funny enough mine has had that code pending for two years. Never turned the CEL on just shows pending. I have yellowtops and have replaced all battery cables. Never has dropped out. If you figure it out let me know, haha.
 

·
Registered
Joined
·
11,216 Posts
Pablo and a master heavy duty mechanic friend are scratching their heads. Does it in the driveway,on the road but it is becoming a daily deal now. I can't imagine the new trucks in ten yrs with so much more complicated electronics? I've got smog coming up in December and must get this resolved or I'll be in the same boat.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #30 ·
Got updates referee called said your truck is federal your smog tech doesn't know what they doing. Take it back. I take it back he says you have to run it as California because their is no veci. There is no veci sticker because its a federal truck and it wasn't required. Does anyone post a picture veci sticker or know a work around?
 

·
Premium Member
2011 Ram 2500 4x4 6.7 68RFE 4 inch lift
Joined
·
1,938 Posts
Go to a referee station and let them do the smog check. You’re just wasting time and money going back to the other place.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #32 ·
I just pulled a Karen and he said he's going to smog it. I just want to avoid this **** completely in the future. Going to order a build sheet showing federal.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #33 ·
Thanks everyone for the insight and advice. Y'all are always helpful in figuring stuff out. I appreciate it.
 

·
Registered
Joined
·
11,216 Posts
Got updates referee called said your truck is federal your smog tech doesn't know what they doing. Take it back. I take it back he says you have to run it as California because their is no veci. There is no veci sticker because its a federal truck and it wasn't required. Does anyone post a picture veci sticker or know a work around?
Give Juan at Pine Valley Auto a go at it.
 
Joined
·
3,500 Posts
Funny enough mine has had that code pending for two years. Never turned the CEL on just shows pending. I have yellowtops and have replaced all battery cables. Never has dropped out. If you figure it out let me know, haha.

Are you able to clear that pending code? I hope that's not affecting the I/M status's.


A new Smarty Junior is about US$500.
If you can even buy a Smarty product in California, I would be looking into that.
Figure out some way to buy one. A friend out of state?

You could sell it after you set your ECM back to stock recouping a large part of that cost.
Can you even privately sell a used Smarty in California?

Setting your ECM to a known stock program level might not resolve the I/M status issue but it would move things forward.
 

·
Registered
Joined
·
11,216 Posts
Smarty's come up for sale on Craigslist. Lots of them out there right after EFI came out.
They can't be shipped to a California address.
 
21 - 39 of 39 Posts
Top