Dodge Cummins Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi, I have a 2004.5 2500 Cummins with the It’s bone stick with a straight pipe. I recently bought a brand new smarty touch tuner and I got it all hooked up and I can’t get it to tune my truck. When I hit the ecm button to go to where I would tune it, it pops up an error and says “ecm not in application mode”. I have no idea what it could be but I’m hoping someone has had a similar problem and may know what I can do to fix it. I’d hate to waste $900 on a tuner for nothing. I’ve tried to contact smarty resource for over a month by calling, emailing, and leaving voicemails but no answer and no reply. I’m not happy with their customer service at all. Any help would be appreciated. Thanks
 

·
Premium Member
Joined
·
6,693 Posts
Where did you get Smarty from?
Just cause new Smarty Touch, should still make sure it is up to date.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I bought it from XDP. I was going to try to update it but I can’t find anything to help me update it. Nothing comes with the smarty to show how to update it and smarty customer service is nearly impossible to get ahold of.
 

·
Registered
Joined
·
803 Posts
What is the firmware on the device currently? You can check it by going to the info menu and then going into the smarty touch info menu. It will then display the firmware currently loaded on the unit. I've worked with Adam at smarty resource and hes always been helpful. Can try emailing him his email is [email protected]
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I finally got ahold of Adam and he is supposed to be sending me a recovery file today so hopefully that will fix my problem. They said it looked like the vin number wasn’t flashed in the ecm correctly. I’m hoping this will fix it so I’m not out $1k for nothing lol
 

·
Registered
Joined
·
2,480 Posts
I finally got ahold of Adam and he is supposed to be sending me a recovery file today so hopefully that will fix my problem. They said it looked like the vin number wasn’t flashed in the ecm correctly. I’m hoping this will fix it so I’m not out $1k for nothing lol
Yes, old known issue apparently with some 3rd gens. The entire VIN wasn't written.

If that doesn't work, the dealer should be able to write the entire VIN to the ECU and then you'd be good to go.
 

·
Premium Member
Joined
·
6,693 Posts
I bought it from XDP. I was going to try to update it but I can’t find anything to help me update it. Nothing comes with the smarty to show how to update it and smarty customer service is nearly impossible to get ahold of.
not sure where you have been looking
 
1 - 7 of 7 Posts
Top