Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Cummins of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
235 Posts
Discussion Starter · #1 ·
so i have les shwab do all my lift work. well i got my 2008 back and drive for like 3 weeks and think to myself " this thing rides like chit!, its so boucy and i could feel a pencil under my tire." well i went down and asked about upgrading my shocks and they told me it wouldn't help much. (tuff country lift) i drove a bout 3 more months and just happen to grab my front shock to find the top is not attached, yet the bolt and washer are on there. both front shocks were like this! so i took it to shwabs and they say "o they must of pulled through........" then i said " OR maybe you didn't hook them up....."


what do you think?
 

·
Registered
Joined
·
3,490 Posts
if it rode like this from day one they didn't put them on, or they totally messed up installing them. i have the same kit and the ride is great.
 

·
Registered
Joined
·
235 Posts
Discussion Starter · #3 ·
well they just called me and told me the washers for the shock slipped the the mount. the washer fell through the mount or something like that. supposedly the lift kit came with to small of washers so they replaced the washers. but myshocks are all rubbed to chit now from not being hooked up
 

·
Registered
Joined
·
639 Posts
Any Pics?
Sounds fishy.
 

·
Registered
Joined
·
235 Posts
Discussion Starter · #5 ·
wow, it rides WAY better with shocks hooked up
now i need to upgrade them to gas
 

·
Registered
Joined
·
1,145 Posts
surprisingly i had this happen to me two weeks ago. Shock pulled through the bolt. I think it was a fluke or failed threads.
 
1 - 6 of 6 Posts
Top