Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your truck HERE to be a part of December's Cummins of the Month Challenge!
1 - 20 of 41 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 · (Edited)
Ill try to figure out how to post photos but heres the story..

Got a 2nd gen swap with everything in my sig.. Race cover.. Got it back drove 7 miles.. Let it eat a little and kaboom! Now had performance loaded from my mini max on.. I need custom tunes i know.. Anarchy is hooking me up.. Great guys.. Just need to get it to the house.. Long story short im getting a loaner turbo and bw is building me a custom turbo... Will be on my truck the 27th... The shop said it was hp related.. What do you guys think.. They said they are building a s471 and i dont see alot of people running one.. Thought the 467.7 flowed more.. Could be wrong.. Didnt see the boost gauge either.. I was trying to keep it on the road lol ill have more details about the turbo they are building tomorrow.. What a nightmare

Oh ya the compressor wheel flew apart.. Shaft was snapped in half.. Ill try to get photos. :banghead:
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #3 ·
Some photos of it
 

·
Premium Member
Joined
·
5,446 Posts
I wouldn't say it is HP related with only 150hp sticks. That should have been in the 700 ish range. Tuning would probably play a roll in it, but to me I would bet money on the installation or a faulty turbo to start with. More on installation.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #5 ·

·
vvvvv Chuck's Ride vvvvvv
Joined
·
6,343 Posts
Was it getting Oil? Hopefully you didn't get anything thru your intercooler. My S469 blew up and thru chunks of wheel all the way thru intercooler and into my head...
 

·
Premium Member
Joined
·
5,446 Posts
I would make damn sure they go through the hole system. Your going to have metal probably everywhere... Even on top of a piston. If it was my truck... I would probably pull the head to make sure.. Just me. But when they come apart like that. There's a good possibility it makes it through the intercooler...
 

·
vvvvv Chuck's Ride vvvvvv
Joined
·
6,343 Posts
I wouldn't say it is HP related with only 150hp sticks. That should have been in the 700 ish range. Tuning would probably play a roll in it, but to me I would bet money on the installation or a faulty turbo to start with. More on installation.
Agreed don't think its Hp Related at all

I would make damn sure they go through the hole system. Your going to have metal probably everywhere... Even on top of a piston. If it was my truck... I would probably pull the head to make sure.. Just me. But when they come apart like that. There's a good possibility it makes it through the intercooler...
Ya don't run truck until you clean EVERYTHING OUT!
 

·
Registered
Joined
·
280 Posts
We almost have the same setup besides me running the 87 turbine and custom tunes, and I haven't had an issue with mine after 20k miles. I don't baby this thing either, but like everyone said, I would bet you had a lubrication issue if it blew that quick. Hope you have better luck with the next one.
 

·
Premium Member
Joined
·
7,027 Posts
Molested chargers that have no hard data is like having a child molester as a baby sister.

Over speed could also be a factor as well.

Just my opinion of coarse.:thumbsup:
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #13 · (Edited)
Thanks for the replies guys.. Ill lay the hammer down tomorrow and make sure they tore everything apart.. And do u think it could have surged so hard it snapped the shaft? I cant remember if i let off the throttle a little or not.. All i remember is throwing some fuel at it and .. Turbo was making my eardrums bleed lol.. And kaboom.. And a ton of white smoke coming out of the exhaust.. Surely i shouldnt have a huge surge issue.. But im no expert
 

·
LIFER
Joined
·
628 Posts
Did this shop install it for you?

This is the second time ive seen this, other incident was because the housing wasnt centered properly. And the wheel made contact.

And that does not appear to be a race cover either.
 

·
Registered
Joined
·
55 Posts
Wow! Sorry to hear that. How old was the turbo? If it was fresh i would think it'd be a manufacture defect.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #17 ·
Wow! Sorry to hear that. How old was the turbo? If it was fresh i would think it'd be a manufacture defect.
Ahh ya i just got it and drove it 7 miles from the shop.. Then it happened.. I really want the 467 but they are having bw build a 471 saying it will be a little stronger.. Suppose to be custom??..Idk if theres any truth to it... Believe it or not.. Trucks been there for 5 weeks.. I could write a book on anger management
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #18 ·
Did this shop install it for you?

This is the second time ive seen this, other incident was because the housing wasnt centered properly. And the wheel made contact.

And that does not appear to be a race cover either.
Are u sure that doesnt look like a race cover? Cuz i paid for one.. Anyme else chime in on this?
 

·
LIFER
Joined
·
628 Posts
Yes, I have a race cover, and it does not look like that. I asked because I was worried you paid for one, being that is not one. Makes me wonder what else this shop is doing shadily.

The 467 is a better charger than the 471, or so my research has lead me to believe.
And I dont see how that could make it beefier as it is the same guts as a 467. Maybe a different thrust bearing.

Also with 150 sticks I believe you would be better off with a 1.1 housing than the .9, again my $.02
 
1 - 20 of 41 Posts
Top