Dodge Cummins Diesel Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter · #1 ·
I just installed a d-tech 62 turbo. The wastegate rod with the jam nuts hits the oil drain. Ive adjusted the rod as far as I can to get it to waste at the desired psi, but I can only get 30 psi out of it cause of the clearance issue. Ive even clearance the tube with a hammer. It helped but not much. Should i get the spring style waste gate or back this one all the way back and get a adjustable boost elbow? thanks :banghead::S:
 

·
Registered
Joined
·
7,762 Posts
Yup, they are a general pain.
I've read that a drain tube for a newer Dodge/Cummins is flexible in that area to accomodate the S300.
 

·
Registered
Joined
·
1,096 Posts
I have the same issue right now but mine is pissing out oil so you want to trade? Don't know how the oil even gets in there. Kinda at a loss for words at the moment its the second one in the truck in under 500km's. Thinking about putting in another turbo from another manufacturer.





 

·
Premium Member
Joined
·
968 Posts
What dose your super b and your s475 spool like???
i as well would like to know. and whats your AR on your s475
im looking into gettin a s472 so it should be fairly similar
 

·
Registered
Joined
·
1,533 Posts
It spools fairly quick, I see boost at 1400 rpm and it takes off rapidly from there if I dont just stand on it. A/r is 1.10

Sent from my DROID X2 using Xparent Blue Tapatalk 2
 

·
Registered
Joined
·
198 Posts
i just took a hammer and a 3/8 drive extension laid it on the tube and hammered a rounded place in the tube... its still close but wastegates at 40 psi like its supposed to
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top