Dodge Cummins Diesel Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
New to cummins forum here! I just bought a 94 dodge that has had some work done. Straight pipe, AFE filter, injector pump turned up. Truck starts and idles fine but while driving will sputter and run rough right off idle at low rpms, kinda like its missing. It clears up pretty fast when given a little pedal and runs smooth down the road. Does it cold or hot. Just changed the fuel filter and that didnt help. Any help or ideas would be greatly appreciated. Thanks
 

·
Premium Member
Joined
·
679 Posts
:welcome:Sounds like you are not getting enough fuel pressure. Might be the lift pump going sour or just getting tired. New lift pump is in the $80 range. Sorry, I left a 1 out, should have said $180. But prices vary from store to store. The last one I saw for an upgraded replacement pump was $169 plus shipping. But the last one I bought was $80, and it was from a new old stock dealer who had bought out a closed Dodge stealership.
 

·
Registered
Joined
·
98 Posts
:welcome: :welcome::welcome:
Hey Jed how many miles are on the truck ? It may need a new liftpump it also sounds like your low idle adjustment is to low too ! A new liftpump is closer to $100.00 bucks not 80.00 just put one on a little over a month ago. It is also a pia :CRY: :CRY: :CRY: I hope it isn't for your sanity. :T: :T::T:
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #4 ·
Thanks for the replys. Motor in the truck has 200K. I will try a lift pump and see if that helps. Should I just get a stock one or are there any good aftermarket?
 

·
Tech Specialist
Joined
·
2,034 Posts
Stock replacement is fine.

I'd put a fuel pressure gauge on it first. That way you can check if its the lift pump or overflow, or something else. No sense in replacing something that is working fine.
 

·
Registered
Joined
·
2,081 Posts
Jed,

Before you start throwing parts at it in hopes of fixing it, email me at [email protected] for my writeup on the 12 valve fuel supply system, how it works and how to fix it.
 

·
Registered
Joined
·
393 Posts
New to cummins forum here! I just bought a 94 dodge that has had some work done. Straight pipe, AFE filter, injector pump turned up. Truck starts and idles fine but while driving will sputter and run rough right off idle at low rpms, kinda like its missing. It clears up pretty fast when given a little pedal and runs smooth down the road. Does it cold or hot. Just changed the fuel filter and that didnt help. Any help or ideas would be greatly appreciated. Thanks
my truck did the same thing, i put a overflow valve on it and cleared it right up
 

·
Registered
Joined
·
120 Posts
my truck does the same thing it drives me nuts. Thought it was an injector issue so i upgraded my injectors and it got worst. lift pump pressure is 20 to 30 psi so i think its fine. My IP only has 75k on it too.
 
1 - 9 of 9 Posts
Top